Thread Closed 
 
Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
custom charset problem
10-21-2011, 07:41 PM (This post was last modified: 10-21-2011 07:46 PM by khoros.)
Post: #1
custom charset problem
Hi,

I have a problem while i try to make a custom-charset where i want include just only those symbols !$%&?= to perform a dictionary attack
The command i use is :
C:\Users\test\Downloads\oclhashcat\maskprocessor-0.65>mp64.exe -o dictcustom -1
?l?u?d -2 !$%&?= ?2?2?2?2
Usage: mp64.exe [options] mask

Try --help for more help.
"?" is not recognized as internal or external command,
an executable program or batch file.

looks like not working.Even if i remove the ? from the charset i get about the same error, like this:

"?2?2?2?2" is not recognized as internal or external command,
an executable program or batch file.


I do something wrong or the program accept just the syntax "?s" as symbols ? so u have to use basically every symbol ? I really need to choose just a little numbers of symbol since i will go for a bruteforce and having at least less symbol will help in how much time would be needed to get the result.

Thanks.
Find all posts by this user
10-21-2011, 10:54 PM
Post: #2
RE: custom charset problem
this is all about windows escape and quote characters, not hashcat.
Visit this user's website Find all posts by this user
07-20-2012, 06:11 PM
Post: #3
RE: custom charset problem
I had the same problem in Backtrack. You have to put the characters between single quotation marks (an apostrophe at the beginning and another at the end of the character sets).
example: 'abcdefABCDEF0123456789@&!?.,*$£_'
This solved the problem for me.
Find all posts by this user
Thread Closed