So close - Only one video card for cracking
#1
Hello everyone. I currently have a dedicated cracking box with external gpu enclosure with 4 Radeon HD 6970s. I have everything working with hashcat, however, when I run hashcat-plus0.06 it only uses ONE graphic cards.

My setup:
Ubuntu 11.10
4 Radeon HD 6970s
AMD Catalyst 11.10 Proprietary Linux x86 Display Driver
AMD APP SDK 2.5

fglrxinfo and amdconfig adapters:
[Image: SkIcQ.png]

If I run amdconfig --initial --adapter=all, I get a blank screen on restart (there IS a signal to the monitor). Same thing happens if I enable the other cards:
[Image: JzvY8.png]

And here is my hashcat running:
[Image: QR2lQ.png]

So basically I'm not really sure how to get all of my cards actually working since every time I try to enable them or install ubuntu updates I get a blank screen after rebooting. Im guessing it has something to do with driver/display settings?

Any help is appreciated. If I can provide any more information let me know. Thanks.

Reply
#2
looks like your cards have not been activated on x11 config. try:

Code:
aticonfig --initial -f --adapter=all

then reboot and try again
Reply
#3
Thanks for the reply atom. I just did that and after putting in my full disk encryption password I get a blank screen (with signal to the monitor). It's very weird, I feel like its sitting at the OS login screen however it's not being shown on my monitor.

Also, before my full disk encryption prompt comes up, I get "error: no video mode activated." After I enter my password I get "mountall: disconnected from plymouth" and then the blank screen.

For reference:
[Image: 3Rlwp.png]
Reply
#4
if you remove the file it should fall back to the previous mode. however, this is defenitly your problem. but its linux/x11 related not hashcat. maybe you have to ask some guys from your linux distribution.
Reply
#5
(11-08-2011, 10:53 PM)atom Wrote: if you remove the file it should fall back to the previous mode. however, this is defenitly your problem. but its linux/x11 related not hashcat. maybe you have to ask some guys from your linux distribution.

Ya after deleting my xorg.conf file it goes back to normal. It's a standard Ubuntu 11.10 64bit install.

I was looking through the xorg.conf file after "aticonfig --initial -f --adapter=all" but am not sure what I would edit to possibly fix this issue.

Code:
Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
    Screen         "aticonfig-Screen[1]-0" RightOf "aticonfig-Screen[0]-0"
    Screen         "aticonfig-Screen[2]-0" RightOf "aticonfig-Screen[1]-0"
    Screen         "aticonfig-Screen[3]-0" RightOf "aticonfig-Screen[2]-0"
EndSection

Section "Module"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[1]-0"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[2]-0"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[3]-0"
    Option        "VendorName" "ATI Proprietary Driver"
    Option        "ModelName" "Generic Autodetecting Monitor"
    Option        "DPMS" "true"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:3:0:0"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[1]-0"
    Driver      "fglrx"
    BusID       "PCI:4:0:0"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[2]-0"
    Driver      "fglrx"
    BusID       "PCI:5:0:0"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[3]-0"
    Driver      "fglrx"
    BusID       "PCI:6:0:0"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[1]-0"
    Device     "aticonfig-Device[1]-0"
    Monitor    "aticonfig-Monitor[1]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[2]-0"
    Device     "aticonfig-Device[2]-0"
    Monitor    "aticonfig-Monitor[2]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[3]-0"
    Device     "aticonfig-Device[3]-0"
    Monitor    "aticonfig-Monitor[3]-0"
    DefaultDepth     24
    SubSection "Display"
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection

Thanks though atom for your help and also the work you do with hashcat.
Reply
#6
I just saw you use unsupported Catalyst 11.10 + SDK 2.5. You must use 11.4 and SDK 2.4, see here: http://hashcat.net/wiki/oclhashcat_catalyst_forceware
Reply
#7
(11-09-2011, 12:15 PM)atom Wrote: I just saw you use unsupported Catalyst 11.10 + SDK 2.5. You must use 11.4 and SDK 2.4, see here: http://hashcat.net/wiki/oclhashcat_catalyst_forceware

Thanks for the tip, not sure how I missed that.

Well I have spent many hours trying to get Catalyst 11.04 to work correctly on my Ubuntu 11.10 box but it's just not happening. I rolled back to using Ubuntu 11.04 and while the driver installation goes smooth and all cards are recognized, after doing "aticonfig --initial -f --adapter=all" I get no signal to my monitor (blank screen) after rebooting. Must have something to do with my xorg.conf? I know this isn't a haschat problem so unless there is an obvious answer don't worry about it. Thanks.

edit- For reference, my xorg.conf is in my previous post.
Reply