hashcat Forum

Full Version: Issues with 7970 + Ubuntu
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Now, I suspect that this might not be a hashcat issue at all, but I thought I'd try this fine forum anyway...

Just build a new rig running Ubuntu 11.10 (x64) and with 2x7970. Latest kernel/updates as of today. I've installed the Catalyst 12.2 drivers according to the following procedure:

When I run oclHashcat (lite-0.09 and plus-0-07) I usually get the following error:
Platform: AMD compatible platform found
ERROR: clGetDeviceIDs() -1

I say *usually* because sometimes after the systems been powered off for a while, it starts working. It works for a while and then, for no apparent reason, I get the same error again.

As I suspected I would run into trouble with this configuration in Linux, I'm also running Windows on the same hardware (dual boot). I have no problems whatsoever in Windows, using the same version (12.2) of the driver. But, I would _really_ like to get this running in Linux... for several reasons!

Anyone have any ideas? Many thanks.
well, installing catalyst and opencl on linux is a pain, no doubt. keep in mind you have to be logged into X11 if you want to use it, otherwise it wont work. also maybe you updated your system packages or ubuntu did it and overwrite the working amd driver with the ubuntu driver, who knows...
Many thanks for pointing me in the right direction Atom - I had totally missed the fact that I had to be logged into X11 so that was the issue!

However, I've run into another issue where I get a "segmentation fault" when I run oclHascat-plus:
[s]tatus [p]ause [r]esume [q]uit => ./oclExample0.sh: line 1: 2049 Segmentation fault ./oclHashcat-plus64.bin example0.hash example.dict -r rules/best64.rule

oclHashcat-lite works just fine though.

The following thread describes a similar issue:

I've ensured that the AMD APP SDK is installed and working OK (before the Catalyst driver), still can't seem to get plus to work.

Appreciate if someone could point me in the right direction... again :-)
yeah thats pretty easy. plus does not support hd7970, thats why it segfaults since its compiled with an to old catalyst. the next thing is that you should remove the sdk since the sdk itself ships and older libOpenCL.so than the catalyst driver does.
OK, many thanks for swift replies!
Hi, I have the same issue with HD7950. ("lite-0.09" is OK, but "plus-0.07" -> segfault)

I'm not sure to understand the answer. Do I must downgrade catalyst or wait for a new release of oclHashcat-plus ?

Many thanks !
you have to wait for an update on plus.
(So sad, I really need mscash v2)

I can't resist to ask this : "Any idea when these cards will be fully supported on oclhashcat-plus ?"

Thanks you very much.
they are now, done with 0.08