hashcat Forum

Full Version: GPU Clustering vclHashcat-plus error
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I'm trying to build a cluster with 2 computers. I follow the example in the wiki: https://hashcat.net/wiki/doku.php?id=vcl_cluster_howto. I'm using Catalyst 12.8 and VCL v1.16.

Everything seems OK I can see the cards using clinfo and run oclHashcat-plus on both computers. When I try to run vclHashcat I get only:
pustiu@Top:~/hashcat$ LD_LIBRARY_PATH=/usr/lib/vcl vclrun ./vclHashcat-plus64.bin --gpu-temp-disable example0.hash example.dict
ERROR: clGetDeviceIDs() -1

I will appreciate any pointers.
does it work without vcl?
(12-08-2012, 02:14 AM)undeath Wrote: [ -> ]does it work without vcl?

Yes, oclHashcat-plus is working on both computers and it recognises all installed cards.
explain your architecture -- do you have a dedicated broker node, or are you running the broker on a compute node? what is the output of ''vclrun clinfo | grep Type'' on your broker?
Hi epixoip,

I tried first as dedicated brocker node, than I tried the brocker in compute mode.
The output of the command with the brocker in compute mode is:
pustiu@Top:~$ vclrun clinfo | grep Type
ERROR: clGetDeviceIDs(-30)

Tho output of clinfo | grep " Name:" is:
pustiu@@Top:~$ clinfo | grep " Name:"
Name: Cypress
Name: AMD Sempron(tm) 140 Processor

If ''vclrun clinfo'' fails, then the problem is with your VCL setup, not with Hashcat.
(12-09-2012, 01:30 AM)epixoip Wrote: [ -> ]If ''vclrun clinfo'' fails, then the problem is with your VCL setup, not with Hashcat.

I tought so and I went trough the VCL installation at least 5 times. Can you see anything wrong with the GPU clustering tutorial for installing VCL http://hashcat.net/wiki/doku.php?id=vcl_cluster_howto ? The only diference is that I use VCL v1.16 instead of v1.15.
VCL 1.16 hasnt been tested yet, stick to VCL 1.15
Reverted to v1.15 with the brocker in dedicated mode.
The command vclrun clinfo | grep Type on the compute node now returns:

pustiu@No5:~# vclrun clinfo | grep Type
VCL: Failed connecting to local VCL daemon: Connection refused
Aborted (core dumped)

Any idea?
any firewall running?
Pages: 1 2