hashcat Forum

Full Version: ?h, ?D, ?R, ?F don't work in 0.15
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I'm having a problem with some of the built-in charsets.
Working: ?l, ?u, ?d, ?s and ?a
Not working: ?h, ?D, ?F and ?R

Syntax error: ?a?h
Syntax error: ?h
Syntax error: ?D
and so on...

Ubuntu 12.04
oclHashcat-plus 0.15
Catalyst 13.4
1xRadeon 7970

Commad line
oclHashcat-plus64.bin -m0 -a3 -o output input -1 ?a?h ?1?1?1?1 --status --status-timer=45 --remove

If I try the same masks with 0.14 it runs as expected.

I have tried putting the masks in a hcmask-file with the same result. ?l?u?d?s work while ?h?D?F?R produce the above error.
These were removed in favor of charset files. Now you would do something like:

cp charsets/special/German/de_cp1252-special.hcchr charset.hcchr

add specials to this file

-a 3 -1 charset.hcchr ?1?1?1?1

The reason this was done was because of encodings. The wasn't possible to put multiple encodings in the same ?X mask and it was causing problem with people trying to use them. Also, this was documented in doc/changes.txt.