hashcat Forum

Full Version: AMD Radeon R9 280X (Asus Matrix) - initial benchmark
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
I apologize if this has been covered already and I didn't notice.

I've been wanting to build an oclHashcat rig for awhile, but when I heard there was a new batch of AMD cards a few months away, I decided to hold off. I just got mine, and dropped it into the Frankenstein machine I'd put together for it back in the summer.

Here are the results from epixoip's script, in case anyone else is curious. This is using the beta1 release of the Catalyst 13.11 driver for Linux, as it's the first release to support the R9 cards. I wanted to stick close to the reference platform, so this is Ubuntu 12.04 LTS with the most current updates.

Not having used the script in the past, is there a standard test.hccap file that is typically used?

I'll poke around in the script itself and see if I can figure out why I didn't get results for a couple of the others.

Hash.Type......: MD5
Speed.GPU.#1...: 6190.8 MH/s

Hash.Type......: Joomla
Speed.GPU.#1...: 5542.8 MH/s

Hash.Type......: SHA1
Speed.GPU.#1...: 2467.6 MH/s

Hash.Type......: MSSQL(2000)
Speed.GPU.#1...: 2014.3 MH/s

Hash.Type......: phpass, MD5(Wordpress), MD5(phpBB3)
Speed.GPU.#1...: 2488.5 kH/s

Hash.Type......: md5crypt, MD5(Unix), FreeBSD MD5, Cisco-IOS MD5
Speed.GPU.#1...: 4186.6 kH/s

Hash.Type......: NTLM
Speed.GPU.#1...: 9044.8 MH/s

Hash.Type......: DCC, mscash
Speed.GPU.#1...: 4570.2 MH/s

Hash.Type......: SHA256
Speed.GPU.#1...: 1202.2 MH/s

Hash.Type......: descrypt, DES(Unix), Traditional DES
Speed.GPU.#1...: 75788.6 kH/s

Hash.Type......: SHA512
Speed.GPU.#1...: 89820.5 kH/s

Hash.Type......: sha512crypt, SHA512(Unix)
Speed.GPU.#1...: 0 H/s

Hash.Type......: WPA/WPA2
Speed.GPU.#1...: 159.6 kH/s

Hash.Type......: LM
Speed.GPU.#1...: 1555.7 MH/s

Hash.Type......: Oracle 7-10g
Speed.GPU.#1...: 451.0 MH/s

Hash.Type......: bcrypt, Blowfish(OpenBSD)
Speed.GPU.#1...: 0 H/s

So pretty consistently about 20% faster than the reference figures posted on the main site for a 7970.
The R9 280X is just a re-branded 7970. There's no difference between the two. The speed-up you are seeing over the benchmarks on the front page come from your boosted clock. Stock 7970 clock is 925 Mhz, Asus Matrix is 1100 Mhz.

Regarding the hccap, I thought it was linked on the wiki somewhere.

The ones you didn't get results for are due to the -n and -u values. The kernel is running longer than the timeout value. I can adjust that.
Wow. Thanks for the tip. I'd been doing a lot of reading about the "R9" series over the summer, and it sure looked like it was going to be more significant than that for the 270X and 280X cards.

At least I still paid less than I would have for a 7970 back when I originally started thinking about this, and it's 20% faster, and it's the first video card I've ever bought where I won't need a second card to have enough outputs to drive all of my displays Smile.

Is this the hccap file that's typically used for testing WPA/WPA2 cracking? It's not named "test.hccap", but it's hosted on hashcat.net (on the Example Hashes page): hashcat.hccap
Yeah, there's a lot of confusion and rumors around the new R line, and the fact that AMD still has not released any official details isn't helping.

The only new products in the R9 line are the 290 (Hawaii Pro) and 290X (Hawaii XT.) Everything else is just a re-brand. That's why the non-reference 280 and 280X are already on the market, because all OEMs had to do was print new boxes Wink

I will probably post a buyer's guide on the forums once I am 100% sure on all the details. But for now, it pretty much breaks down like this:

R5 210 => HD 5450/6350/7350
R5 220 => HD 6450/7450
R5 230 => HD 7470
R7 240 => Crippled version of HD 8570
R7 250 => HD 8570
R7 260 => Re-worked HD 7770 with 128 more stream processors
R7 260X => HD 7790
R9 270 => Re-worked HD 7870
R9 270X => Re-worked HD 7870
R9 280 => HD 7970
R9 280X => HD 7970 Ghz Edition
R9 290 => Re-worked and underclocked HD 7970 with 512 more stream processors
R9 290X => Re-worked and underclocked HD 7970 with 768 more stream processors

Edit: typo in last line.
Interesting. Thanks!

I got the WPA/WPA2 benchmark working using the example file I mentioned above, and I added the score to my original post. No surprises there.

This is probably telling you something you already know, but I tried extending the runtime for the two that were giving me no results, and even at 30 seconds, they still show nothing. However, if I continually check the status while they're running, I get these values temporarily - they just revert back to 0 before the test times out:

sha512crypt, SHA512(Unix)
Speed.GPU.#1...: 14864 H/s

bcrypt, Blowfish(OpenBSD)
Speed.GPU.#1...: 4493 H/s

Both of those values are what I'd expect based on the other results. The non-zero numbers started showing up after about 25 seconds for the sha512crypt test, and after 11-12 seconds for the bcrypt test.
Hi guys,

Ive just built myself a new pc with a R9 280X so ran the benchmark in ubuntu 13.10 after installing the official AMD drivers, heres my results. Can anyone shed some light as to why they're all slower than blincoln's?

Mine is the Sapphire R9 280X and Catalyst Control Centre is reporting a 1500MHz clock at stock.

Hash.Type......: MD5
Speed.GPU.#1...:  5727.1 MH/s

Hash.Type......: Joomla
Speed.GPU.#1...:  5146.2 MH/s

Hash.Type......: SHA1
Speed.GPU.#1...:  2288.8 MH/s

Hash.Type......: MSSQL(2000)
Speed.GPU.#1...:  1865.6 MH/s

Hash.Type......: phpass, MD5(Wordpress), MD5(phpBB3)
Speed.GPU.#1...:  2260.7 kH/s

Hash.Type......: md5crypt, MD5(Unix), FreeBSD MD5, Cisco-IOS MD5
Speed.GPU.#1...:  3895.8 kH/s

Hash.Type......: NTLM..
Speed.GPU.#1...:  8328.9 MH/s

Hash.Type......: DCC, mscashCredentials, mscash...
Speed.GPU.#1...:  4243.0 MH/s

Hash.Type......: SHA256
Speed.GPU.#1...:  1115.3 MH/s

Hash.Type......: descrypt, DES(Unix), Traditional DES
Speed.GPU.#1...: 70125.6 kH/s

Hash.Type......: SHA512
Speed.GPU.#1...: 83166.5 kH/s

Hash.Type......: sha512crypt, SHA512(Unix)
Speed.GPU.#1...:        0 H/s

Hash.Type......: WPA/WPA2
Speed.GPU.#1...:   136.3 kH/s

Hash.Type......: LM
Speed.GPU.#1...:  1431.4 MH/s

Hash.Type......: Oracle 7-10gES(Oracle)...
Speed.GPU.#1...:   418.3 MH/s

Hash.Type......: bcrypt, Blowfish(OpenBSD)
Speed.GPU.#1...:        0 H/s

Benchmark complete.

Also... Ive just found a command to monitor the GPU load and its locked at 66%. According to htop oclHashcat is the top 3 processes running at 37%, 25% and 10%

I thought oclHashcat was supposed to be light on the cpu and make full use of the gpu, can anyone explain any of it please?

Your results are only about 10% lower than mine, so my guess is it has to do with the clock rate? The Matrix is factory-overclocked to about 20% greater than normal speed, as epixoip mentioned earlier. 1500 MHz doesn't sound right, because that would mean it was running at something like 150% standard clock rate. It's not liquid nitrogen-cooled, is it? Smile

FWIW, I posted this in another thread, but just to cover it here in the originating thread as well, my Matrix card completely died the fifth day that I had it - I've tried it in two different PCs and they won't even POST with it installed.

I hadn't even had time to use it to crack any real-world hashes - just ran a few quick benchmarks, and then a few days later while it was displaying my desktop, the screen went white and it stopped working.

Reading NewEgg reviews, it looks like this whole line of theirs is incredibly unreliable, and Asus support has gone way downhill. It's now a month later and I still don't have a replacement. I'm going to try a different brand, and looking at the posts regarding the 290-series cards, I think I'll go with a different 280X instead.
Sorry, I misread my clocks, that 1500 is my memory clock speed, my stock core speed is 1020.

Sad to hear about your card, mines Sapphire and I haven't had any issues yet and I'm using it for gaming too.

I don't know if there's some kind of CPU bottleneck in hashcat because as I posted in another thread (Low GPU load) I was only getting 66% GPU load in hashcat until I overclocked my CPU which then got me 87% GPU load.
Any thoughts?
Is the R9290 working yet?
Hi together,

im working on a windows with a AMD Radeon R9 280X. But Hashcat always say OpenCL self-test failed.
Does anybody else have this problem? Or perhaps a solution?
Pages: 1 2