hashcat Forum

Full Version: hcstat: Could not load data
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello Hashcat community.

I created a .hcstat file, with the latest hcstatgen.exe from utils 1.0, from a very large dictionary (15 GB).

When I try to use it with statprocessor.exe though, I get the feedback that “wpa.hcstat: Could not load data”. If I use the default .htstat file that comes bundled with oclHashcat, everything works fine. The file that I generated is 25,3 MB. I don’t know if that is important. I just mention it.

Would anybody want to look into this? Is it a bug probably or I am doing something wrong?

Thank you very much.
Trying to troubleshot the problem, I saw that the hashcat-utils “word-parsing engine has a minimum and maximum allowed word-length range (like in “len” example).

See utils.c header:
#define FGETS_MIN 1
#define FGETS_MAX 16”.

So, I removed from my dictionary everything longer than 16 characters, and I re-run the hcstatgen.exe. The .hcstat file that was created worked fine with statprocessor. Though it was 300mb in size.
I was having the same issue. Downloaded older versions of hcstatgen/statsprocessor and it worked fine.