hashcat Forum

Full Version: Sapphire R9 270 Dual-X slower than HD5850
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Hi there,

i just wanted to confirm something I've stumbled upon while trying out different Graphic Cards I have lying around.

I've got a Sapphire R9 270 Dual-X and an Sapphire Radeon HD5850 Toxic. The Results for cracking SHA512 seem ok as the R9 is noticable quicker then the HD5850 (About 195 MH/s for the R9 compared to the ~145 MH/s for the HD5850) but when I try the OS X 10.9 Hash the R9 is way slower than the HD5850.

On Workprofile 3 the R9 cracks ~1300 H/s and the HD5850 scratches at the 1900 H/s Mark. I've tried the Hash on my Linux Installation as well as on my Windows Installation (Linux = xUbuntu 14.04 x64 with Catalyst 14.9 and oclHashcat 1.31 ; Windows = Windows 7 Ultimate x64 with Catalyst 14.9 and oclHashcat 1.31).

Now the Question: Is this normal? Can I assume that its Hash related or am I missing something here?! The Parameters I used were the following:

sudo ./oclHashcat64.bin -m 7100 -a 3 -w 3 --status <hash> -1 ?l?d?s

I would appreciate any Suggestions as to why the R9 is significantly slower at this Hash than the Hd5850. If its an Architecture related Problem of the Card any Suggestions as to which Cards I should buy to improve the Performance when cracking OS X 10.9 Hashes whould be nice!

Thanks in Advance
doesn't make sense, something is not right. it might be because you aren't specifying a mask and thus aren't gaining full acceleration for smaller keyspaces.

Thanks for the Response! As suggested I've tried the Hash with a specified Mask but the Performance results in exactly the same H/s (About 1300). I've used ?a and in a second try ?l for the Mask.

sudo ./oclHashcat64.bin -m 7100 -a 3 -w 3 --status <hash> ?a?a?a?a?a
sudo ./oclHashcat64.bin -m 7100 -a 3 -w 3 --status <hash> ?l?l?l?l?l

As I don't know if the 195 MH/s for the SHA512 is acceptable for the R9 270 I can't draw any Conclusions if the Card might be somehow broken.
What's the output of ./oclHashcat64.bin -m 7100 -b on each GPU?

Also why are you using sudo?

Attachted are the Outputs for both the R9 and the HD5850. Regarding the sudo - Read it in the Tutorial I was using and stuck with it, bad habbit I guess. Works of course without the sudo as well :-)

Thanks again for your Time!
Hm, doesn't make a whole lot of sense.

The R9 270 is showing up as Pitcairn, but Pitcairn is HD 7850 -- there aren't any Pitcairn-based R9 GPUs, and your core clock doesn't match the stock clock of any Pitcairn-based GPUs nor the R9 270 (overclocking?) So I'm not sure what you have. If you're positive it's an R9 270 then it might be a bug in the driver or in Hashcat. That might be the source of the problem, if Hashcat is loading a vector kernel instead of a scalar kernel.

Theoretical numbers based on the core clocks you've provided, assuming you really do have an R9 270 and HD 5850 and are overclocking both:

HD 5850 = 1440 cores @ 765 Mhz
R9 270 = 1280 cores @ 945 Mhz

(1440 * 765) / (1280 * 945) = 0.91

R9 270 should be ~10% faster (and actually a little bit more than that since you're talking VLIW5 vs GCN.)

However, if it is Pitcairn then the 5850 would be ~ 15% faster.

So either way the math doesn't add up.

Ok, that is strange! It is definitly a R9 270 - At least thats what it says on the Sticker thats on the Backside of the Card...
As it seems Hashcat recognizes the HD5850 correctly because the HD5850 as a Cypress Architecture. This throws the Question why the R9 is not recognized correctly :-\

So the next steps would be to try an older Version of Hashcat and if that doesn't work maybe an older Version of Hashcat compared with an older Catalyst Version, correct?


I just verified that the Card is recognized by the Catalyst Driver and...well...it says that its a R9 200 Series Card *sigh*
what does the output of ''clinfo | grep Name'' show on the R9 270?

It shows not what it should *sigh* The Output is pitcairn or to be exact

Platform Name:                 AMD Accelerated Parallel Processing
Platform Name:                 AMD Accelerated Parallel Processing
Name:                          Pitcairn
Name:                          AMD Athlon(tm) II X4 640 Processor
Actually Pitcairn is GCN, I was thinking it was VLIW5, but that's just 7350 - 7670. So Hashcat should be loading a VLIW1 kernel regardless. But it may still be doing something else that is suboptimal resulting in poor performance. Either way I think the driver is the source of your issues.
Pages: 1 2