hashcat Forum

Full Version: ERROR: No NVidia compatible platform found
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Hello I am trying to use cudaHascat to crack my wpa when I run:

./cudaHashcat64.bin -m 2500 -a3 ../psk-01.hccap abcdABCD pause

I get:
Generating bitmap tables with 16 bits...

ERROR: No NVidia compatible platform found

I found a few pages in this forum; however, it seems all other problems are slightly different. I did however, follow this pages: https://hashcat.net/forum/thread-2121.html advice checking the following things:

nvcc -V
nvcc: NVIDIA (R) Cuda compiler driver
Copyright (c) 2005-2013 NVIDIA Corporation
Built on Wed_Jul_17_18:36:13_PDT_2013
Cuda compilation tools, release 5.5, V5.5.0

dmesg | grep -i nvidia
[    4.052736] nvidia: module license 'NVIDIA' taints kernel.
[    4.055430] nvidia: module verification failed: signature and/or  required key missing - tainting kernel
[    4.058742] [drm] Initialized nvidia-drm 0.0.0 20150116 for 0000:02:00.0 on minor 0
[    4.058753] NVRM: loading NVIDIA UNIX x86_64 Kernel Module  340.96  Sun Nov  8 22:33:28 PST 2015
[    4.690370] input: HDA NVidia HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:02.0/0000:02:00.1/sound/card1/input16
[    4.690833] input: HDA NVidia HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:02.0/0000:02:00.1/sound/card1/input17
[    4.691530] input: HDA NVidia HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:02.0/0000:02:00.1/sound/card1/input18
[    4.691643] input: HDA NVidia HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:02.0/0000:02:00.1/sound/card1/input19

cat /proc/driver/nvidia/version
NVRM version: NVIDIA UNIX x86_64 Kernel Module  340.96  Sun Nov  8 22:33:28 PST 2015
GCC version:  gcc version 4.8.4 (Ubuntu 4.8.4-2ubuntu1~14.04)

ls /dev/nvidia*
/dev/nvidia0  /dev/nvidiactl

Sat Jan 16 14:08:04 2016       
| NVIDIA-SMI 340.96     Driver Version: 340.96         |                       
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|   0  GeForce GTX 560     Off  | 0000:02:00.0     N/A |                  N/A |
| 19%   37C    P0    N/A /  N/A |    393MiB /  1023MiB |     N/A      Default |
| Compute processes:                                               GPU Memory |
|  GPU       PID  Process name                                     Usage      |
|    0            Not Supported                                               |

lspci -vnn | grep -i VGA -A 12
02:00.0 VGA compatible controller [0300]: NVIDIA Corporation GF114 [GeForce GTX 560] [10de:1201] (rev a1) (prog-if 00 [VGA controller])
    Subsystem: ASUSTeK Computer Inc. Device [1043:83b4]
    Flags: bus master, fast devsel, latency 0, IRQ 53
    Memory at f8000000 (32-bit, non-prefetchable) [size=32M]
    Memory at e8000000 (64-bit, prefetchable) [size=128M]
    Memory at f0000000 (64-bit, prefetchable) [size=64M]
    I/O ports at e000 [size=128]
    [virtual] Expansion ROM at fa000000 [disabled] [size=512K]
    Capabilities: <access denied>
    Kernel driver in use: nvidia

02:00.1 Audio device [0403]: NVIDIA Corporation GF114 HDMI Audio Controller [10de:0e0c] (rev a1)
    Subsystem: ASUSTeK Computer Inc. Device [1043:83b4]

However, on the other page it turned out the driver was installed incorrectly and didn't output anything for the last two queries.

I am running 1 GTX 560 and I am using the 64 bit version of oclHashcat (from the nVidia section) of the download page.

Any suggestions are much appreciated!
Are you root?
(01-16-2016, 11:09 PM)epixoip Wrote: [ -> ]Are you root?
Ahhh of course it needs to be run as root.... No I wasn't that fixed it. Thank you!