hashcat Forum

Full Version: The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali)+gtx1080+hashcat
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I have hit a wall trying to get Hashcat going on The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) and I could use some help as I have seen any docs that give me a hint about what to do next. I followed these instruction http://docs.The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali).org/general-use/install-nvidia-drivers-on-The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali)-linux

Hashcat fails to find the GTX1080.

hashcat -m 2500 -a 3 my.hccap
hashcat (v3.10) starting...
OpenCL Platform #1: Mesa, skipped! No OpenCL compatible devices found
ERROR: No devices found/left

Here are my particulars:

uname -a
Linux crackerjack 4.7.0-kali1-amd64 #1 SMP Debian 4.7.5-1kali3 (2016-09-29) x86_64 GNU/Linux

glxinfo | grep "direct render"
direct rendering: Yes

 lsmod |grep nvidia
nvidia_drm             45056  2
drm_kms_helper        147456  1 nvidia_drm
drm                   364544  5 drm_kms_helper,nvidia_drm
nvidia_modeset        765952  7 nvidia_drm
nvidia              11472896  110 nvidia_modeset

              total        used        free      shared  buff/cache   available
Mem:       32900248      736872    31193836       35112      969540    31695456
Swap:             0           0           0

 lspci |grep -i nvidia
03:00.0 VGA compatible controller: NVIDIA Corporation GP104 [GeForce GTX 1080] (rev a1)
03:00.1 Audio device: NVIDIA Corporation GP104 High Definition Audio Controller (rev a1)

Any feedback on how to get this going would be awesome.

It looks like OpenCL is not installed?


that was helpful.

I ran
aptitude install nvidia-opencl-common
aptitude install nvidia-cuda-toolkit

and that appears to have taken me closer to the mark, but still no joy.

root@crackerjack:# hashcat -m 2500 -a 3 my.hccap
hashcat (v3.10) starting...

OpenCL Platform #1: NVIDIA Corporation
- Device #1: GeForce GTX 1080, 2028/8113 MB allocatable, 20MCU
- Device #1: WARNING! Kernel exec timeout is not disabled, it might cause you errors of code 702
See the wiki on how to disable it: https://hashcat.net/wiki/doku.php?id=timeout_patch

OpenCL Platform #2: Mesa, skipped! No OpenCL compatible devices found

WARNING: NVML library load failed, proceed without NVML HWMon enabled.
Hashes: 1 hashes; 1 unique digests, 1 unique salts
Bitmaps: 16 bits, 65536 entries, 0x0000ffff mask, 262144 bytes, 5/13 rotates
Applicable Optimizers:
* Zero-Byte
* Single-Hash
* Single-Salt
* Brute-Force
* Slow-Hash-SIMD
Watchdog: Temperature abort trigger set to 90c
Watchdog: Temperature retain trigger set to 75c

Initializing device kernels and memory...

ERROR: clCreateContext(): CL_UNKNOWN_ERROR
I appear to have resolved the problem.

I uninstalled all of the The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) packages that had the name nvidia in them, and the installed the driver download directly from nvidia.

after, that, magic happened. we'll see what pain this causes me later but for now i am cooking with gas.