hashcat Forum

Full Version: Optimized kernel giving different results
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
I was writing some rules and decided I should use a simple set of md5 hashes to test the rules. In doing this I noticed some behavior I did not expect. With the optimized kernel, the result stored in the pot file is missing the rules generated part of the match.

So for example, when running the optimized kernel like so:

./hashcat -m 0 -r rules/T0XlC-insert_00-99_1950-2050_toprules_0_F.rule -O forest2020.hash forest2020.txt

output looks like this:

./hashcat --show forest2020.hash 

If I delete the .pot file and run again omitting the -O flag, I get the correct results:

Is this intended behavior? I'm using latest git pull as of today:

hashcat (v6.1.1-66-g6a419d06) starting...

* Device #1: GeForce GTX 1660 SUPER, 5504/5943 MB, 22MCU

OpenCL API (OpenCL 1.2 CUDA 11.0.228) - Platform #1 [NVIDIA Corporation]
* Device #2: GeForce GTX 1660 SUPER, skipped
Rolling back before commit a1b5af44330b1ba36eedd3030583f07c6623ee87 fixes the issue. Will file a bug at github.
Thanks! I see it's at https://github.com/hashcat/hashcat/issues/2539

(Also that is a hilarious username)