hashcat Forum
[Solved] dictionary cleaning - Printable Version

+- hashcat Forum (https://hashcat.net/forum)
+-- Forum: Misc (https://hashcat.net/forum/forum-15.html)
+--- Forum: General Talk (https://hashcat.net/forum/forum-33.html)
+--- Thread: [Solved] dictionary cleaning (/thread-1593.html)

Pages: 1 2

[Solved] dictionary cleaning - aaaaa1 - 09-24-2012

hi guys!
can somebody help me to clean my dictionaries?
in my dicts i can see many lines like on next screenshot:
in which way i can remove lines contains unprintable characters from my lists?
sed -i '/\x00/d'
from x00 to x09, its work fine, but for 011 to 031 chars not work
also with
sed '/\011/d'
sed "/\c K/d"
sed '/'"$(printf '\011')"'$/d'

have no luck
help, please BASH Guru!

RE: dictionary cleaning - atom - 09-24-2012

you tried strings?

strings < in.dict > out.dict

RE: dictionary cleaning - aaaaa1 - 09-24-2012

strings < in.dict > out.dict remove all from list
may by need some options?

RE: dictionary cleaning - aaaaa1 - 09-25-2012

Nobody dont know?

RE: dictionary cleaning - epixoip - 09-25-2012

nobody know what? you said "yes!" and that strings removed everything from the list. did you have another question?

RE: dictionary cleaning - aaaaa1 - 09-25-2012

You right, sorry, my reply was not correct.
this function remove ALL content from list, not only lines what i need to remove.
I do not know why?
Can somebody show me any working example how to remove lines with unprintable characters?
Again very sorry, i just install my LinuxMint 13 Mate (2 weeks ago) and im newbie in this OS.
And my "Yes!" means - i tried this strings and have negative result.
Still need help!

RE: dictionary cleaning - epixoip - 09-25-2012

it's kind of a tricky subject and requires some experience.

the issue might be solely with your language settings. just because your system is unable to represent a character doesn't mean it's unprintable. it could also be why strings and other console utilities are failing.

can you show us the output of ''echo $LANG'' and ''file <hashfile>''?

RE: dictionary cleaning - aaaaa1 - 09-25-2012

echo $LANG

file hashfile
hashfile: ERROR: cannot open `hashfile' (No such file or directory)
where must to be file hashfile?

RE: dictionary cleaning - M@LIK - 09-25-2012

He meant your dictionary file.

RE: dictionary cleaning - aaaaa1 - 09-25-2012

OK, sorry
03.txt: ASCII text