hashcat Forum
cuModuleLoad() 209 error - Printable Version

+- hashcat Forum (https://hashcat.net/forum)
+-- Forum: Deprecated; Ancient Versions (https://hashcat.net/forum/forum-46.html)
+--- Forum: Very old oclHashcat-plus Support (https://hashcat.net/forum/forum-23.html)
+--- Thread: cuModuleLoad() 209 error (/thread-2719.html)

cuModuleLoad() 209 error - arcticplatypus - 10-18-2013

I continue to get this error.

Hashes: 5 total, 1 unique salts, 5 unique digests
Bitmaps: 8 bits, 256 entries, 0x000000ff mask, 1024 bytes
Workload: 4096 loops, 800 accel
Watchdog: Temperature abort trigger set to 80c
Watchdog: Temperature retain trigger set to 80c
Device #1: GeForce GTX 660 Ti, 2048MB, 980Mhz, 7MCU
Device #1: Kernel ./kernels/4318/m0000_a3.sm_30.64.ptx
ERROR: cuModuleLoad() 209

My OS is windows 8 64-bit.
Graphics Card: NVIDIA Geforce GTX 660ti 2 Gb dedicated memory
Please help me with this.

RE: cuModuleLoad() 209 error - Rolf - 10-18-2013

A couple of questions
1. Is there a "m0000_a3.sm_30.64.ptx" file in oclhc/kernels/4318?
2. What's your Forceware driver version?
3. Full command line?

RE: cuModuleLoad() 209 error - KamX - 11-15-2013

I have a similar problem using cudaHashcat-plus v0.15.

My GPU is a Tesla M2090, 5375MB, 1301Mhz, 16MCU running on a windows 2012 server. If I'm not wrong the driver is the Forceware 306.79.

The strange thing is that cudahaschat 0.14 works perfectly... If someone can help me, it would be perfect

RE: cuModuleLoad() 209 error - atom - 11-15-2013

if you have the same situation, please answer rolf's questions first

RE: cuModuleLoad() 209 error - master_zion - 11-17-2013

cudaHashcat-plus v0.14 works fine and I'm trying to test the Truecrypt module ( -m 6211 ).

I also tried to install theses drivers but I received error during the kernel module build.

$ls -lh kernels/4318/m0000_a3.sm_30.64.ptx
-rw------- 1 master master 463K Aug 24 14:36 kernels/4318/m0000_a3.sm_30.64.ptx

$uname -a
Linux server 3.2.0-4-amd64 #1 SMP Debian 3.2.51-1 x86_64 GNU/Linux

$cat /etc/issue
Debian GNU/Linux 7

$ nvidia-smi
Sun Nov 17 06:19:13 2013
| NVIDIA-SMI 4.304.88 Driver Version: 304.88 |
| GPU Name | Bus-Id Disp. | Volatile Uncorr. ECC |
| Fan Temp Perf Pwr:Usage/Cap| Memory-Usage | GPU-Util Compute M. |
| 0 GeForce GTX 650 | 0000:01:00.0 N/A | N/A |
| 21% 34C N/A N/A / N/A | 15% 307MB / 2047MB | N/A Default |

cudaHashcat-plus v0.15 by atom starting...

Hashes: 6494 total, 1 unique salts, 6494 unique digests
Bitmaps: 16 bits, 65536 entries, 0x0000ffff mask, 262144 bytes
Workload: 512 loops, 80 accel
Watchdog: Temperature abort trigger set to 90c
Watchdog: Temperature retain trigger set to 80c
Device #1: GeForce GTX 650, 2047MB, 1202Mhz, 2MCU
Device #1: WARNING! Kernel exec timeout is not disabled, it might cause you errors of code 702
ERROR: cuModuleLoad() 209

RE: cuModuleLoad() 209 error - philsmd - 11-17-2013

From http://hashcat.net/oclhashcat-plus/
Quote:NV users require ForceWare 319.37 or later

I don't think it will work for you w/ an older driver just because a newer driver is difficult (has problems etc) to compile/install/run.

So this is a hard requirement and you shouldn't even think of testing w/ a older driver, because it can't work (in general).

Quote:I also tried to install theses drivers but I received error during the kernel module build.
You must investigate these errors and try to fix them (cleanly remove older drivers, remove remaining libCudas, check if the requirements for the 319.37 driver (install) are met - linux kernel -> maybe too new/old debian version - header files installed?, etc...). There could be infinite reasons why it fails... but 319.37 definitely works on ubuntu / debian and many other distros w/o problems.
Therefore you should read the error messages (of the driver installer) and/or log files and find a solution to install the driver (e.g. search on google for the error message).

RE: cuModuleLoad() 209 error - Kgx Pnqvhm - 11-17-2013

The NVIDIA driver needs to have CUDA 5.5.