hashcat Forum
Radeon HD 5770 - No open Cl found ??? (Half Answerd) - Printable Version

+- hashcat Forum (https://hashcat.net/forum)
+-- Forum: Misc (https://hashcat.net/forum/forum-15.html)
+--- Forum: Hardware (https://hashcat.net/forum/forum-13.html)
+--- Thread: Radeon HD 5770 - No open Cl found ??? (Half Answerd) (/thread-7413.html)

Radeon HD 5770 - No open Cl found ??? (Half Answerd) - mysterdee888 - 04-03-2018

Hi, i recently purchased a Radeon HD 5770 for hashcat use, 

After reading up on the forums i found that i could run this graphics card and that it would work on hashcat also.

I am still convinced this graphics card will work, because of other people running the same card with the same issue i have RESOLVED.

Basically, when i run hashcat in GPU o get the following error

No OPENcl Device found...

BUT My system is showing it with opencl

So there should be no issues,

However my system info does not display any openCl either

Iv read up on more threads and find that this is a resolvable issue if i can get the OpenCl rekognized by hashcat.

I find this problem will also occure with other programs not finding the openCl

So i need to sort this out.

Does anybody have any idea of what i should do.

Iv been advised to run hascat 3.2 . which i did.

Still same error.

Is there some sort of tweaking or driver required to make it OpenCl compatible or sumthing.

Here is the link from a guy who had the same card with the same issue..(He resolved it)

slyexe undefined 
Junior Member

Posts: 31
Threads: 0
Joined: Nov 2017

Only issue with using OLD Hardware is that your support will be limited. I use to run a 5770 HD prior to my 1070 and had no issues with it. I was able to get ~38-44K h/s for WPA2 on Hashcat 3.20 from my recollection. However, the newest rendition of hashcat may throw errors as it is not OpenCL compliant, so you may need toggle a few parameters to get it to work. Also, using older HCCAP format in older hashcat versions has the possibility of "missing" the correct key just for your knowledge. I have not encounter this issue, but that was the reason for the upgrade to HCCAPX.

Good luck on your venture!

Computer Specs


Graphics Card Manufacturer - Powered by AMD
Graphics Chipset - AMD Radeon HD 5700 Series
Device ID - 68B8
Vendor ID - 1002
SubSystem ID - 200B
SubSystem Vendor ID - 1787
Revision ID - 00
Bus Type - PCI Express 2.0
Current Bus Settings - Not Available
BIOS Version -
BIOS Part Number - 113-SBSM2G01-00R-01
BIOS Date - 2009/12/12 00:30
Memory Size - 1024 MB
Memory Type - GDDR5
Memory Clock - 1200 MHz
Core Clock - 850 MHz
Total Memory Bandwidth - 76 GByte/s
2D Driver File Path - /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/Class/{4d36e968-e325-11ce-bfc1-08002be10318}/0002

Radeon Settings Version - 2016.0226.1531.27895
Driver Packaging Version - 15.301.1901-160226a-318064E
Provider - Advanced Micro Devices, Inc.
2D Driver Version -
Direct3D® Version -
OpenGL® Version -
OpenCL™ Version -
AMD Mantle Version -
AMD Mantle API Version - Not Available
AMD Audio Driver Version -

Dell Inc. Dimension XPS
  • System Manufacturer Dell Inc.
  • System Model Dimension XPS
  • System Type Desktop
  • Motherboard Manufacturer Dell Inc.
  • Motherboard Product 0U7084
  • BIOS Version UNKNOWN
  • SMBIOS Version 2.3
Operating System
Microsoft Windows 7 Ultimate (32-bit)
  • OS Build 6.1.7601
  • Locale English (United Kingdom)
  • Windows Directory D:\Windows
  • System Directory D:\Windows\system32
  • .NET Framework Versions 2.0.50727.5420, 3.0.30729.5420, 3.5.30729.5420,, 4.7.02558
  • Default Internet Browser Internet Explorer 11.0.9600.17843
  • Installed Internet Browsers Firefox Developer Edition, Google Chrome, Internet Explorer 11.0.9600.17843
Intel® Pentium® 4 CPU 3.20GHz
  • Manufacturer GenuineIntel
  • Description x86 Family 15 Model 3 Stepping 4
  • Architecture x86
  • # of Cores 1
  • Current Clock Speed 3192 MHz
  • Current Voltage 1.9
  • Level 2 Cache 1024 Kb
  • Level 3 Cache 0 Kb
  • Processor Id BFEBFBFF00000F34
  • Revision 772
  • Availability Running at full power
  • Search support for 'Intel® Pentium® 4 3.20GHz'
AMD Radeon HD 5700 Series
  • Adapter Compatibility Advanced Micro Devices, Inc.
  • Video Processor AMD Radeon Graphics Processor (0x68B8)
  • Resolution 1440 x 900
  • Bits Per Pixel 32
  • Number of Colors 4294967296
  • Refresh Rate - Current 60 Hz
  • Refresh Rate - Maximum 60 Hz
  • Refresh Rate - Minimum 59 Hz
  • Driver Provider Advanced Micro Devices, Inc.
  • Driver Version 15.301.1901.0
  • Driver Date 2/26/2016
  • Adapter DAC Type Internal DAC(400MHz)
  • Adapter RAM 1.00 GB
  • Availability Running at full power
  • Status This device is working properly.
  • Location PCI bus 1, device 0, function 0
  • Device Id PCI\VEN_1002&DEV_68B8&SUBSYS_200B1787&REV_00\4&701F2C4&0&0008


RE: Radeon HD 5770 - No open Cl found ??? With Answer (need help) - mysterdee888 - 04-03-2018


This link is telling me to uninstall my driver

Run the sdk and catalyst installers to repair the installation, then uninstall everything through the control center. After you reboot install only catalyst. Just delete the sdk you downloaded and don't install it. Then reboot and post a screenshot of which catalyst components are installed.

So let me get this right. i uninstall everything and re-install without what part??? sdk .

Im not sure what im not installing here?

any ideas any1.

(whats the sdk for a start)

>>>>quote "Just delete the sdk you downloaded and don't install it"<<<


RE: Radeon HD 5770 - No open Cl found ??? (Half Answerd) - mysterdee888 - 04-04-2018

AMD Radeon Software Crimson Edition" (15.12 or later)

Im running v17.x.x.x +++( so no problems with the GPU compatibility)

And I managed to get it passed the no openCl error by installing an opencl driver, supposedly compa with this graphics card, However i got an Error, Native opencl.

So im thinking i need the right openCl that will be compatible with this device, However its a difficult task...

Any advice anybody, Thanks.

RE: Radeon HD 5770 - No open Cl found ??? (Half Answerd) - mysterdee - 04-05-2018

Sussed It.

3days and 3 late nights (its now 6.12 am - 3rd long night LOL)

See pics..