Problem installing catalyst 13.1 in debian
Sorry for the long waiting, I have some problems understanding what we do, also I tried to get help from the team working in The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) linux, and they said that they are not going to fix anything. they gave some commands to "fix" the problem but that commands are only the peak of iceberg.

Special thanks to philsmd Big Grin

Let's begin :3]

this tuto was made using a pc with linux, kernel:
Linux The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) 3.7-trunk-686-pae #1 SMP Debian 3.7.2-0+kali5 i686 GNU/Linux

1. lets see try to find out what you have installed by issuing following command

sudo dpkg --get-selection|grep -i fglrx

we should remove the drivers installed by the distro and try to do a clean install, at the ouput we shoul have someting like this:


then we should uninstall all using purge, we should write in the terminal something like this, if you have more, the add them:

apt-get remove fglrx-atieventsd fglrx-control fglrx-driver fglrx-modules-dkms glx-alternative-fglrx glx-alternative-fglrx libfglrx-amdxba1:i386

WARNING!!!! after this you should have your installer downloaded, cause after rebooting you won't have graphics at all, just command line !!!!

download the version 13.1 catalyst from:


uncompress it and then

sudo chmod +x

Suggestion, download the file in /root then you won't have to be writing the full path were is it, you will save time.

Also, you have to download the patch for the .run file from:

Then we reboot, and if your computer is well configurated even only with the command line you should have internet cause we will need it.
The problem with this kernel is that the file "version.h" is not in the correct folder, the only will do a simbolic link. also you will need maybe other pc or write all this commands in a papper. I guess you're now in your command line the follow the next steps:

to avoid any problems we will check if we have the headers installed:

apt-get install linux-headers-$(uname -r)

If they are installed uninstall them and the reinstall(optional step)

apt-get remove --purge linux-headers-$(uname -r)

then again

apt-get install linux-headers-$(uname -r)

after the install of the headers we will try to locate were the "version.h" is located

locate version.h

in our case was located in


the correct place should be(that was written in our logs file when tried to install, this folder can be other)


then in this step could be different from other versions, cause in the bug trackers of The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) linux said that the folder should be /usr/src/ but in our case was /lib/modules/ , we made the symlink with this commands:

ln -s /usr/include/linux/ /lib/modules/3.7-trunk-686-pae/build/include/linux/

At this moment all should work, and the drivers could be installed, if you want install them or keep working in the command line. I installed and rebooted to use graphics and work faster, then write in your command line:


after installing, reboot, and the graphics should work. Hope you remember that we donwloaded the patch, now we will use it to patch the installer.
first we need to extract the .run installer where we consider necessary.

root@The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali):~# ./ --extract ./src
Creating directory ./src
Verifying archive integrity... All good.
Uncompressing AMD Catalyst(TM) Proprietary Driver-9.012...............................
root@The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali):~# cd ./src

then you should go where the file fglrx-3.7.patch was saved, and patch the file firegl_public.c located in the extracted .run file, in our case in the folder:



root@The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali):~# cd ..
root@The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali):~# patch -Np1 --verbose < fglrx-3.7.patch
Hmm...  Looks like a unified diff to me...
can't find file to patch at input line 3
Perhaps you used the wrong -p or --strip option?
The text leading up to this was:
|--- firegl_public.c    2012-12-26 14:53:14.843334069 +0700
|+++    2012-12-26 15:23:23.220996869 +0700
File to patch: /root/src/common/lib/modules/fglrx/build_mod/firegl_public.c    
Patching file /root/src/common/lib/modules/fglrx/build_mod/firegl_public.c using Plan A...
Hunk #1 succeeded at 3892.
Hunk #2 succeeded at 3926.
Hunk #3 succeeded at 3949.
Hunk #4 succeeded at 3962.
Hunk #5 succeeded at 4008.
Hunk #6 succeeded at 4047.
Hunk #7 succeeded at 4065.
Hunk #8 succeeded at 4090.
root@The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali):~# cd ./src
root@The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali):~/src# ./ 9.002 --install

after that the drivers should be installed without any problem, then reboot your machine. and enjoy hashcat Big Grin
let's see a screenshot from my terminal. Big Grin

any questions, ask us Big Grin

Messages In This Thread
RE: Problem installing catalyst 13.1 in debian - by eljolot - 04-16-2013, 07:09 PM