nested sha1
Hmmm, indeed. But I wonder why oclHashcat is reporting 'Line-length exception' for every hash I try where hashcat is working quite OK with the whole set not complaining about anything? Both tools are at the recent available revisions, OS Win10 64bit with latest crimson software (radeon, r9 295x2) - not sure if that matters. Tried combinations with ascii salt and hex salt - same result. Hashcat is cracking passwords, oclhashcat is complaining about line length.

Salt is 12 characters long (hex24 character long of course), pass (hash) is 40 characters long.

EDIT: got answer on IRC from philsmd (thanks!) - hope you don't mind if I put it here.

<@philsmd> redmine uses a fixed salt length (32), oclHashcat does this additional check
           when parsing hashes (for performance reasons, only exactly 32 are allowed):

So it seems that hashcat do not care about salt length when using "-m 7600" options, but oclHashcat does for performance reasons.

NeoTherm1c pointed out that there is already md5($salt.md5($str)) algo supported so perhaps sha1($salt.sha1($str)) should be requested.

I gave it a shot, and here is the request:

Messages In This Thread
nested sha1 - by d2 - 12-22-2015, 01:32 AM
RE: nested sha1 - by philsmd - 12-22-2015, 11:11 AM
RE: nested sha1 - by d2 - 12-22-2015, 12:29 PM