Installing AMD Catalyst on newest version of The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) (32)

I have been at this for DAYS!!! I do not want to install windows and run a The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) vm or anything.. i just hate windows, to much maintaining.


I have installed 32bit The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) linux on my computer and before doing anything i updated to the latest kernel version (3.12) and then saw that the beta driver for catalyst only supported it, so i went ahead and installed it there.. but.. It gave me an error during the installation:

(Something about DKM and fglrx not properly compiling [i will have the exact error for you guys tomorrow).

So I did aticonfig blahblah and rebooted (also added radeon.modeset to grub) then when i try to go into system settings (to change display) it gives me an error:

The program gnome-control-center received an X Window System error.

SO i googled around for 4 hours and FOUND NOTHING TO FIX IT. I tried reinstalling, purging, and i even removed gnome and tried to use KDE THEN that gave me an ERROR! (Seg fault when trying to actually run catalyst and what do you know.. NO FIX).

So i was wondering, has anyone got AMD catalyst to work with The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali)-1.06 (whatever the newest version is with Kernel 3.12).. Because i haven't and i could really use some help here.. Worst case scenario i have to install windows 8 (school has it for free), but i want to try to get this to work..


Intel Pent G2020
2x Radeon HD 7870 [only have one installed because they didn't come with a crossfire bridge -.-]
MSI motherboard
32gb RAM
1000W PSU

so yeah.. anyone get it to work? Because i would love to know.. it always seems the problem is Xserver and the actual driver fglrx..

Thanks in advance and for reading some of my anger (4 days............).

P.S. I have tried with the following operation systems to install:

Ubuntu 32 and 64 never worked..
The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) 32 and 64 never worked.. (partially.. booted fine but would not let me open some gnome things [i have tried kde and others.. nothing..]).

Also, for some reason whenever i run (apt-get update even apt-fast update) it takes for ever at the end to Read package lists... (literally about 25-30 minutes to finish..) this happened after i accidentally had a duplicate entry into the sources.list file so does anyone know how to fix this?

Messages In This Thread
Installing AMD Catalyst on newest version of The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) (32) - by 3kings - 01-15-2014, 08:32 AM