password length for -a attack against truecrypt
Hi guys, newbie here Smile
I need to recover the password of an old tc hidden volume I created a long time ago.
The password is very long but I think I remember the first 34 characters Big Grin
I created a wordlist with maskprocessor with almost a billion passwords inside and I extracted the hash with dd (first 512 Bytes, right?).
Now I just need to launch something like this
hashcat -a 0 -m 62xx file.hash file.dict
That's it.
Is there a way to do that or the limit ( I think for the -a attack) is insuperable?
Thanks in advance Smile

p.s. I'm on a Mac and I installed hashcat with brew because the other way caused problems :\
p.p.s. the password shouldn't be longer than 40-42 characters... now I'm testing the range 36-40

I've tried with an alternative dict file that contains only short words (6 letters) and it doesn't work either :\ What am I doing wrong?
The message says:

Minimum password length supported by kernel: 0
Maximum password length supported by kernel: 64

No hashes loaded.
No hashes loaded.
if TrueCrypt uses a hidden partition or volume, you need to skip the first 64K bytes (65536) and extract the next 512 bytes

so if you look close -> No hashes loaded

inside your file.hash no valid hash was found, so hashcat is unable to start the attack
Unbelievable... I read that, I swear... but I misunderstood the meaning... I was thinking about an entire partition on the hard drive... sorry, I'm gonna try right away Smile
it's working thank you!
ahah I tried with John the Ripper but there was some problem, perhaps I had to buy the license or I don't know... then I tried with OTFBrutusGui and it was working but it said it was gonna take 4 months or something LOL
Now with my very humble 5500xt it's just 13 hours, I just hope I set it right... and I hope it's not gonna get broken because I'm on a hackintosh and I don't think I have the necessary settings that allow me to monitor the gpu temperature but I'm gonna try Smile