V56 is up
hey beta-testers,

v56 fixed a very evil bug that lead to total unpredictable other bugs. please do all your testing again Smile

Tnx atom Smile in Barcelona atm but will be back in UK Friday so will do testing then.
Since after plus-0.09b45 up to plus-0.09b57, when I try:
hc64p -a3 --bf-min=8 --markov-disable --force 00000000000000000000000000000000 ?a?a?a?a?a?a?a?a
I get:
[s]tatus [p]ause [r]esume [b]ypass [q]uit => ERROR: cuMemcpyDtoD() 1
Try with b58 pls, just uploaded
b58 also fixed this for both amd and nvidia, pls verify:

Quote:- For -m 2711 vBulletin > v3.8.5, Nothing works
- For -m 2811 vBulletin > v3.8.5, Nothing works
Just tried -m2(6|7)11 on all lengths, all attack-modes. Result: All Works!
Also "cuMemcpyDtoD() 1" is gone! Thanks atom!
Windows7 64-bit, nVidia, 304,79 beta, plus-0.09b58.

Testing is way much easier than I thought. Going to hit other hash-types!
System: Windows 7 64 bit, catalyst 12.8 HD5750, oclhashcat-plus beta 56

I did my usual test on all algos and all modes. I won't specify what is working since now it's almost everything. Also, all the crashes are fixed!

For -m 1710 sha512($pass.$salt), bruteforce of length 4 does not work. Everything else works.
For -m 2711 and -m 2811, the usual bug. Dictionary attack works but all other mode fails.

That's it. I will try to reproduce the -m 1710 bug again and report if I find something useful.

For the AMD side, v 0.09 is almost ready to go! I can't wait to test the Nvidia now (probably this evening).
Finally, all tests are done!
Results: (If no note is given means all is working perfectly!)
-m130: Same problem as -m131, -m132.
-m500: All works EXCEPT it fails to crack any 1-character-long password on all attack modes (Only -a0 and -a3 can get that though).
-m1600: Same problem as -m500.
-m1710: Interestingly, None of -a1, -a6 and -a7 work, on all lengths.
-m2500: SKiPPiNG.
-m3000: Worked well, But this BUG (https://hashcat.net/forum/thread-1216.html) still exists. Funny it's giving me different results this time, but still wrong results!
-m3100: I'm not sure about this algo, when I use -a3, all is being cracked but if len(pass) > 8 : its truncating the passes to 8. Other attacks don't do that, they act just like a regular MD5.
-m131: All good, except -a7 seems to have a problem.
-m132: Exact same problem of -m131. Only 1-character-long password is found when doing -a7, which should never happen with -a7 (it works with a mask!).
-m2811: MyBB1.2+ uses ?l?u?d_len(8) salt, please add an exception.
I'm keeping this one-damn-fine version =D

System: Windows7 64-bit, nVidia, 304,79 beta, plus-0.09b58.
Thanks to atom's perl code and my MasterHasher.php.
Thanks for the test results, very very very helpful. Indeed I focuses on amd mostly, but will not try to fix stuff on nvidia, too.

This bugfixing round was really neccessary Smile
continue here pls: