Not working after reverting catalyst drivers
I was using the latest Catalyst, and noticed the warning not to use them, and noticed it was very slow compared to what I was expecting. So I reverted to Catalyst 13.1, and just to be sure I deleted the oclhashcat-plus directory and re-extracted, and rebooted.

Now it just refuses to work. If I run it on a valid hash (including the example commands) it unceremoniously dumps me out and tells me "oclHashcat-plus64.exe has stopped working". I'm using Windows 7 64 bit, the GPU is an AMD 6900 series, either 6950 or 6970 (can't seem to find out without opening the case and looking).

This really sound like a driver problem. Please use the suggested methods to cleanely uninstall previous drivers: i.e. use free version of driver fusion.
If it worked before on your system, it should work again but you need to setup the driver correctly.

I hope I understood this correctly: reverted to Catalyst 13.1 implies oclHashcat was working before w/ 13.1 !?
No, it was working before with 13.4. But it was slow and warned me against it so I reverted. I'll try using driver fusion and report back.
Looks like that fixed it, thanks.