Stuck for days, probably a simple fix, please help!
So I was testing my network which is ATT. Most ATT routers use a 10 digit numerical code for WPA2. So I generated a dictionary file of every possible 10 digit number, captured the packet, converted it, etc.

Put the code into hashcat, and it took like 4 days but it says that it solved it and was successful.

The problem is that I didn't specify an output file when I was using the cmd line. So I know that it was probably solved because the password was in the dictionary file. However, how do I verify what the password is? Whenever I rerun the command, it finishes immediately, which I read is because something is saved in a pot file when you solve a hash.

Basically, my question is, I have the pot file, how do I verify what the wpa password is? I'm using the Cuda version of hashcat. Seems simple but I"ve been searching for days and everything I tried doesn't work.
cudaHashcat64 -m 2500 --show hash_file.hccap

if you did specify a session name (--session) for cracking the hash(es) you need to specify it for the --show command as well.

Also see:
If you have the .pot file like you said, just open it with a text editor and it should be there in the format SSID : Password (that's what I remember). Just make sure that you have the right pot file. Like philsmd mentioned, the pot file is named like the session so if you set --session=1, your pot file will be named 1.pot. The default is cudahashcat.pot or oclhashcat.pot depending of which architecture you use.
Thank you guys I did open the pot file and it was there!
also you do not need to create a file with 10 length numeric. using a bruteforce mask of ?d?d?d?d?d?d?d?d?d?d should do the same thing. the plus side you don't need to store a huge wordlist file.