Core dumped or Im doing something wrong?
Hi everybody!

Im learning how to use hashcat, when I run on my machine:

hashcat --status --status-timer 10 --opencl-device-types 1 -a 3 -m 0 <md5 hashcode of three letter here> ?l?l?l

I get:

hashcat (v3.10) starting...

OpenCL Platform #1: Intel(R) Corporation
- Device #1:        Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz, 1986/7944 MB allocatable, 4MCU

Hashes: 1 hashes; 1 unique digests, 1 unique salts
Bitmaps: 16 bits, 65536 entries, 0x0000ffff mask, 262144 bytes, 5/13 rotates
Applicable Optimizers:
* Zero-Byte
* Precompute-Init
* Precompute-Merkle-Demgard
* Meet-In-The-Middle
* Early-Skip
* Not-Salted
* Not-Iterated
* Single-Hash
* Single-Salt
* Brute-Force
* Raw-Hash
Watchdog: Temperature abort trigger disabled
Watchdog: Temperature retain trigger disabled

Initializing device kernels and memory...[1]    5579 segmentation fault (core dumped)  hashcat --status --status-timer 10 --opencl-device-types 1 -a 3 -m 0  "?l?l?l

dmesg | tail: (I ran sometimes before post)

[223418.696750] wlp8s0: associated
[223418.696793] IPv6: ADDRCONF(NETDEV_CHANGE): wlp8s0: link becomes ready
[223419.425896] usb 1-1.6: device descriptor read/64, error -110
[223430.003634] usb 1-1.6: device not accepting address 37, error -32
[223430.070309] usb 1-1.6: new full-speed USB device number 38 using ehci-pci
[235475.552885] hashcat[4087]: segfault at 0 ip           (null) sp 00007ffc65a9a468 error 14 in hashcat[400000+7f000]
[235484.002473] hashcat[4174]: segfault at 0 ip           (null) sp 00007ffe254f0618 error 14 in hashcat[400000+7f000]
[235489.938221] hashcat[4263]: segfault at 0 ip           (null) sp 00007ffeb48d77b8 error 14 in hashcat[400000+7f000]
[236523.799038] usb 1-1.4: reset high-speed USB device number 30 using ehci-pci
[236529.310733] hashcat[5579]: segfault at 0 ip           (null) sp 00007ffd15e38888 error 14 in hashcat[400000+7f000]

Is it a bug or am I doing something wrong? If its a bug, how can I provide more information to help solve this?
Im using Manjaro Linux (same repos from ArchLinux), my OpenCL driver is AUR's intel-opencl-runtime.

Thanks in advance!
Yes, please post clinfo output

Number of platforms                               1
 Platform Name                                   Intel(R) OpenCL
 Platform Vendor                                 Intel(R) Corporation
 Platform Version                                OpenCL 1.2 LINUX
 Platform Profile                                FULL_PROFILE
 Platform Extensions                             cl_khr_icd cl_khr_global_int32_base_atomics cl_khr_global_int32_extended_atomics cl_khr_local_int32_base_atomics cl_khr_local_int32_extended_atomics cl_khr_byte_addressable_store cl_khr_depth_images cl_khr_3d_image_writes cl_intel_exec_by_local_thread cl_khr_spir cl_khr_fp64
 Platform Extensions function suffix             INTEL

 Platform Name                                   Intel(R) OpenCL
Number of devices                                 1
 Device Name                                     Intel(R) Core(TM) i5-3230M CPU @ 2.60GHz
 Device Vendor                                   Intel(R) Corporation
 Device Vendor ID                                0x8086
 Device Version                                  OpenCL 1.2 (Build 25)
 Driver Version                        
 Device OpenCL C Version                         OpenCL C 1.2
 Device Type                                     CPU
 Device Profile                                  FULL_PROFILE
 Max compute units                               4
 Max clock frequency                             2600MHz
 Device Partition                                (core)
   Max number of sub-devices                     4
   Supported partition types                     by counts, equally, by names (Intel)
 Max work item dimensions                        3
 Max work item sizes                             8192x8192x8192
 Max work group size                             8192
[1]    29567 segmentation fault (core dumped)  clinfo

dmesg for last error:

[27579.385526] wlp8s0: send auth to f8:1a:67:56:50:c8 (try 1/3)
[27579.387469] wlp8s0: authenticated
[27579.388214] wlp8s0: associate with f8:1a:67:56:50:c8 (try 1/3)
[27579.392449] wlp8s0: RX AssocResp from f8:1a:67:56:50:c8 (capab=0x431 status=0 aid=2)
[27579.392572] IPv6: ADDRCONF(NETDEV_CHANGE): wlp8s0: link becomes ready
[27579.392770] wlp8s0: associated
[27579.452097] wlp8s0: AP f8:1a:67:56:50:c8 changed bandwidth, new config is 2452 MHz, width 1 (2452/0 MHz)
[27580.448306] usb 1-1.6: device descriptor read/64, error -110
[28625.595228] clinfo[29567]: segfault at 0 ip           (null) sp 00007ffc1b5b1398 error 14 in clinfo[400000+e000]
[28643.780669] clinfo[29747]: segfault at 0 ip           (null) sp 00007ffc394d07c8 error 14 in clinfo[400000+e000]

Thanks in advance!
Since clinfo is not part of hashcat but crashing too I'd say your OpenCL installation is broken. You need to fix that first.