Strange Hashcat Freezing Issue
I recently added a Nvidia 2070 Super along side an RX 580 in my system. I've started to get an issue with hashcat freezing. Hashcat does not provide any error it just freezes and stops running. What's strange is this only happens when using a small set of rules. When I use a larger set of rules it will run for hours without ever freezing. Furthermore if I run the small set of rules using just one GPU (either one) it also never freezes. When the freeze happens it starts to log the error "Page fault failed for pfn[0] = 0x0" multiple times a second in syslog.log and kern.log. I'm unsure why it only happens when running a small set of rules when the GPUs are not even being pushed hard. Anyone have any idea of what could be happening?

System Specs:
MSI Performance Gaming Plus AMD X470
AMD Ryzen 5 2600
Corsair Vengeance LPX 16GB (2x8GB) DDR4 @ 3200
CORSAIR RM850, 850 Watt, 80+ Gold Certified
Samsung 970 EVO SSD 500GB - M.2 NVMe

Nvidia 2070 Super
AMD RX 580

OS and Hashcat Version:
Ubuntu 18.04
Hashcat Version: v5.1.0-1736-gb1d5f92c

Example Command:
./hashcat.bin -m 1000  work.txt -a 0 --outfile cracked.txt --remove ./wordlists/* -d 1,2 -O --status --status-timer 60 -w 3 -r rules/best64.rule
** I have tried with -w 2, -w 1, and the issue still occurs while using both GPUs **

Here is a screenshot of what the terminal looks like when this happens. It never continues past this point and you have to CTRL-Z to end it.

Any help is greatly appreciated.