hashcat Forum

Full Version: Help with R9 290 WPA speed
You're currently viewing a stripped down version of our content. View the full version with proper formatting.

I'm running Ubuntu 13.10 with two R9 290 GPUs and Catalyst 13.11 beta drivers (the 13.12 drivers refuse to install for some reason).

Anyway I ran the oclHashcat benchmark. It took c.45 minutes to complete but that was more to do with each kernel apparently taking ages to load. My hash rate was approx 20% of "PC5" on the hascat homepage for every kernel, which I'm not surprised about (8x 290x's vs. 2x 290's). WPA/WPA2 speed was reported as 295 kH/s.

Here's my question: when I run a dictionary attack on a sample *.hccap file, I only see about 13 kH/s. So the rockyou.txt dictionary takes nearly 20 mins to exhaust. How can I get the 'real life' WPA/WPA2 speed up to the benchmark reported 295 kH/s? Any tips would be much appreciated!

try benchmarking with mode -a 3 (mask attack ?a?a?a?a?a?a?a?a?a ) instead of wordlist and play about about with the -n -u flags.

or add a rules file in conjunction with wordlist.
Thank you. That was it, set the -n and -u flags to match the numbers spat out by the benchmark mode and it's up to 300kH/s. Cheers
everything you described is exactly what i talked about in my first review of the 290X.

you really need to be running 13.12. also, use od6config to configure your gpus appropriately. start by just running
od6config --autofix
Thanks - great review btw. Yeah, I had problems with 13.12. Even on a clean Ubuntu install the Catalyst gui install just crapped out at the kernel post-processing step, which resulted in booting to a black screen with a cursor. Even dropping to a shell and purging seemed to be difficult. So I fell back to the 13.11 beta. Maybe that's a weekend project for me....!
there's some patch you have to apply to Catalyst to make it compile on Ubuntu 13.10 and other distributions with newer kernels. i don't have a link to that patch, but i'm sure someone on here does. but this is why i stick to LTS releases only. AMD does not list 13.10 as a supported distribution for a reason.