hashcat Forum
Parse Error - Printable Version

+- hashcat Forum (https://hashcat.net/forum)
+-- Forum: Support (https://hashcat.net/forum/forum-3.html)
+--- Forum: hashcat (https://hashcat.net/forum/forum-45.html)
+--- Thread: Parse Error (/thread-6207.html)

Parse Error - pestyDragon - 01-14-2017

Trying to run hashcat: but get (Failed to parse hashes using the 'native hashcat' format) can't seem to figure out what I am doing wrong or what is causing the problem.

/hashcat64.bin -m 3000 --username -l ?u?d?s /Documents/OffSec/labHashes/1.5-ntlm ?1?1?1?1?1?1?1

hashcat (v3.30) starting...

OpenCL Platform #1: NVIDIA Corporation
* Device #1: GeForce GTX 980, 1009/4037 MB allocatable, 16MCU

Failed to parse hashes using the 'native hashcat' format
No hashes loaded

RE: Parse Error - rico - 01-15-2017

No attack mode specified. Add -a 3

Custom charset is -l instead of -1. Change to -1 ?u?d?s

I haven't seen your hashlist format so possibly try without --username

Double-check that -m 3000 (and not 1000) is the right hash mode.

/hashcat64.bin -m 3000 -a 3 --username -1 ?u?d?s /Documents/OffSec/labHashes/1.5-ntlm ?1?1?1?1?1?1?1

RE: Parse Error - pestyDragon - 01-15-2017


./hashcat64.bin -m 3000 -a 3 --username -1 ?u?d?s /Documents/OffSec/labHashes/ntlmTest ?1?1?1?1?1?1?1

also tried with -m 1000 as well. Still get,

Failed to parse hashes using the 'native hashcat' format

hash file looks like: 

If I try it without the usernames using this command:

./hashcat64.bin -m 1000 -a 3 /Documents/OffSec/labHashes/1.5-ntlm ?1?1?1?1?1?1?1

I get this error.

Hash '/Documents/OffSec/labHashes/1.5-ntlm': Line-length exception

Contents from the hash file:

RE: Parse Error - rico - 01-15-2017


Those hashes aint -m 3000 (LM) but could be -m 1000 (NTLM). The "Line-length exception" message is because your first hash is 31 bytes instead of 32. hashcat will continue after skipping this.

EDIT: Oh yeah, remove the hashes before the ban-hammer does what it does best.