hcxdumptool - missing frames w/ filtering
#44
Well, tried wifi_labtools w/ ArchLinux vs _Kali on RPi4-8GB
AP was ON. Three clients were connected: printer, Android 8 and Android 9 phones. Scanning time 5 minutes.
Hashlines obtained by ArchLinux: 4 hashes from printer, 2 hashes from Android 8 and 1 hash from Android 9.
Hashlines obtained by _Kali: 3 hashes from printer, 1 hash from Android 8 and 1 hash from Android 9.
Power consumption was around 4W for both ArchLinux and _Kali.
7:5 ArchLinux won ūüŹÜ

Now problem is that ArchLinux is so tricky to run that I was able to install and run labtools only. After that pacman was broken and I just gave up using it. Full upgrade -Syu makes ArchLinux unbootable system on my RPi4.

A found Manjaro is based on ArchLinux too, like kids version Smile. Indeed system itself runs very smoothly and after -Syu it work perfectly, but again problem with how to install wifi-labtools. After installing packages (make, gss and git) I tried to install wifi-labtools, but got error:
Code:
$ sudo make install
cc -O3 -Wall -Wextra  -o hcxlabgetm1 hcxlabtool.c -DGETM1 -DSTATUSOUT
make: cc: No such file or directory
make: *** [Makefile:10: build] Error 127
I guess something still missing in Manjaro, but so far could find any solution. Could you please advice?
Reply


Messages In This Thread
RE: hcxdumptool - missing frames w/ filtering - by pipss - 01-28-2023, 09:42 AM