Another question about mask to deal with space
(11-27-2013, 06:40 AM)mastercracker Wrote:
(11-21-2013, 02:38 AM)gale6k Wrote: My total cmd is :
oclHashcat-plus64.exe -a 3 -m 1000 --force -o "ntlm_out.txt" --outfile-format=2 --markov-disable --gpu-temp-disable -i --increment-min=8 --increment-max=8 "ntlm.txt" '?a?a?a?a?a?a 2'

this cmd exit with mask is too small

the password may be start with six ?a and end with space and 2.
I don't know why you got that error but by default, oclhashcat does the mask as is (without increment). You then ask for increment with -i and then abolish it by setting the same min and max. It does not make sense. Just try this:

oclHashcat-plus64.exe -a 3 -m 1000 --force  -o "ntlm_out.txt" --outfile-format=2 --markov-disable --gpu-temp-disable "ntlm.txt" '?a?a?a?a?a?a 2'
If it does not work, try replacing the ' by " (replace single quote by double quote). I don't think it will change anything but you never know. Finally, it's in your best interest to use markov chains so I would remove the --markov-disable switch.

Thanks very much.

I remove the -i, try to replace the ' by ", but still does not work.
I think it because in the windows cmd "main(int argc, char *argv[ ])", when a space appears in the command's args, the argc will plus 1, and anything behind the space will generate a new argv element.

I have test all 33 printable special characters, eight characters(space"&,<>^|) have the same problem.

Finally, I put the space to a space.hcchr file, and use "-1 space.hcchr ?a?a?a?a?a?a?12", then it works.

Messages In This Thread
RE: Another question about mask to deal with space - by gale6k - 12-04-2013, 07:58 AM