nvidia-settings errors in Ubuntu 16
First of all, this is my fan speed script with my GTX 1080.  I run it prior to launching hashcat.

nvidia-settings -a GPUFanControlState=1
nvidia-settings -a GPUTargetFanSpeed=75
nvidia-settings -a GPUPowerMizerMode=1
nvidia-settings -a GPUGraphicsClockOffset[3]=200

(yes, I'm only running 75 percent with my GPU fan; I never break 60C with a single GPU)

In Ubuntu 16, while trying to execute my fan speed script, I was getting this error:

"Failed to connect to Mir: Failed to connect to server socket"

I corrected the above error by running, "apt-get install unity8-desktop-session-mir"

*Edit on August 6th, 2017*

If you are running headless and before you install the unity8-desktop-session-mir package in order to correct the "Failed to connect to Mir:" issue, try exporting your DISPLAY environment variable first.

export DISPLAY=:0

*Edit on August 6th, 2017*

"nvidia-settings -a GPUFanControlState=1" and "nvidia-settings -a GPUPowerMizerMode=1" can now execute, but the other commands won't.

"nvidia-settings -a GPUTargetFanSpeed=75" returns with:
ERROR: Error assigning value 75 to attribute 'GPUTargetFanSpeed' (hostname:0[fan:0]) as specified in assignment

       'GPUTargetFanSpeed=75' (Unknown Error).

And "nvidia-settings -a GPUGraphicsClockOffset[3]=200" returns with:
Quote:** (nvidia-settings:2388): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

Some other details about my environment follow:

I am attempting to run "headless" with lightdm set to auto login.  This worked flawlessly in Ubuntu 14, but doesn't seem to in 16.


On boot, with the above in my lightdm.conf, on boot, I get a window that says, "The system is running in low graphics mode"

I used to just get a black screen in Ubuntu 14 and everything worked.

When hashcat is done, I also want to be able to run my "back to normal" script:

nvidia-settings -a GPUGraphicsClockOffset[3]=0
nvidia-settings -a GPUPowerMizerMode=0
nvidia-settings -a GPUFanControlState=0

But I'm having some issue that I haven't identified yet.  

Any help is greatly appreciated since this is a show stopper for me.

Messages In This Thread
nvidia-settings errors in Ubuntu 16 - by devilsadvocate - 11-12-2016, 07:17 PM
RE: nvidia-settings errors in Ubuntu 16 - by red - 04-03-2017, 06:17 PM