Plugins 2500/2501 and 16800/16801 are deprecated
(12-05-2023, 01:53 PM)yuXfar Wrote: running both cpmmands

─(The-Distribution-Which-Does-Not-Handle-OpenCL-Well (The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali))㉿The-Distribution-Which-Does-Not-Handle-OpenCL-Well (The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali)))-[~]
└─$ hcxdumptool *.pcapng -o test.hc22000                 
hcxdumptool: invalid option -- 'o'
hcxdumptool 6.3.2-70-gdf8f2e6 (C) 2023 by ZeroBeat
This is a penetration testing tool!
It is made to detect vulnerabilities in your NETWORK mercilessly!

$ hcxdumptool -h for an overview of all options
$ hcxdumptool --help for an example and trouble shooting
┌──(The-Distribution-Which-Does-Not-Handle-OpenCL-Well (The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali))㉿The-Distribution-Which-Does-Not-Handle-OpenCL-Well (The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali)))-[~]
└─$ cat test.hc22000
cat: test.hc22000: No such file or directory

Ugly copy and paste error. We are now on level of converting the hashes and hcxpcapngtool should do that:
$ hcxpcapngtool *.pcapng -o test.hc22000

I've a way of to many open terminals here (coding new features, testing a new device, running hashcat and answering questions).
Thank you so much for the help dev. 🙇‍♀️🙇🙇
so I've tried something, i replace dumpfile.pcapng to the pcapng file that showed up again after i ls command, so here is the result

Warning: out of sequence timestamps!
This dump file contains frames with out of sequence timestamps.
That is a bug of the capturing tool.

session summary
processed pcapng files................: 1
Looks looks there is a dump file from another tool inside your directory that hcxpcapngtool has converted.
This bug has been fixed on hcxdumptool and hcxpcapngtool since v6.2.9.
Hi dev, where can I find the results of the attack I made after the attack is done?
Here in case of hcxdumptool (dump file in pcapng format):
stored by hcxdumptool in working directory
-w <outfile>   : write packets to a pcapng-format file named <outfile>
                  default outfile name: yyyyddmmhhmmss-interfacename.pcapng

Here in case of converted files by hcxpcapngtool (hash file in hc22000 format)
stored by hcxpcapngtool in working directory

-o <file> : output WPA-PBKDF2-PMKID+EAPOL hash file (hashcat -m 22000)
get full advantage of reuse of PBKDF2 on PMKID and EAPOL

Here in case of hashcat (recoverd PSK in hashcat out file format):
via hashcat show option
--show                     |      | Compare hashlist with potfile; show cracked hashes   |
Here in case of hashcat (recoverd PSK in hashcat pot file format):
stort in hashcat config directory
$ cat $HOME/.hashcat/hashcat.potfile
$ cat ~/.hashcat/hashcat.potfile
Thanks dev, so I just realized this but when I run wordlist attack command, I didn't specify my own network to be attacked.