illegal hardware instructions
Hello Im having a problem with hashcat any help would be much appreciated. Hashcat does not seem to be using video card either, only cpu is in the list.

zsh: illegal hardware instruction 

some info

hashcat (v6.2.5) starting in backend information mode

OpenCL Info:

OpenCL Platform ID #1
  Vendor..: The pocl project
  Name....: Portable Computing Language
  Version.: OpenCL 2.0 pocl 1.8  Linux, None+Asserts, RELOC, LLVM 11.1.0, SLEEF, DISTRO, POCL_DEBUG

  Backend Device ID #1
    Type...........: CPU
    Vendor.ID......: 128
    Vendor.........: GenuineIntel
    Name...........: pthread-Intel(R) Pentium(R) CPU 6405U @ 2.40GHz
    Version........: OpenCL 1.2 pocl HSTR: pthread-x86_64-pc-linux-gnu-skylake
    Processor(s)...: 4
    Clock..........: 2400
    Memory.Total...: 2801 MB (limited to 512 MB allocatable in one block)
    Memory.Free....: 1368 MB
    OpenCL.Version.: OpenCL C 1.2 pocl
    Driver.Version.: 1.8

bare metal install on a HP laptop
see landing page

GPU Driver requirements:
AMD GPUs on Linux require "RadeonOpenCompute (ROCm)" Software Platform (3.1 or later)
AMD GPUs on Windows require "AMD Radeon Adrenalin 2020 Edition" (20.2.2 or later)
Intel CPUs require "OpenCL Runtime for Intel Core and Intel Xeon Processors" (16.1.1 or later)
NVIDIA GPUs require "NVIDIA Driver" (440.64 or later) and "CUDA Toolkit" (9.0 or later)

does your laptop has a discrete gpu or just embedded?

laptops (maybe except for gaming laptops) are not quite suitable for cracking

what do you want to crack/attack?
Its Embedded. Trying to crack doing some try hack me.
It worked on my other laptop running vmware.
(02-17-2022, 04:54 PM)VonBaron Wrote: Its Embedded. Trying to crack doing some try hack me.
It worked on my other laptop running  vmware.

intel integrated GPU opencl runtime is broken, you have to stick to CPU only
How do I use CPU then and ger rid of zsh: illegal hardware instruction
add -D1 as option which tells hashcat to use CPU only,

regarding zsh, dont know, try starting hahscat with sudo
on Windows it is possible to use Intel GPU with Hashcat v5.1.0 using option -D 2 --force
Please see

Please share your opinion why Hashcat v6.2.5 is about 200 times slower than v5.1.0 in my case.
NEVER EVER NEVER use --force unless you are a developer

--force will ignore all warnings and build in safety checks and therefore can or will produce wrong outputs

intel integrated gpu opencl runtime is broken! its like using the orignal hp-35 and wondering why "exp(ln (2.02))=2" easy answer the original hp-35 has a bug

reagarding your question / thread, see my answer there (will take a look after this one)
Thank you for the help I really appreciate it