Segmentation Fault when checking status
Here's what I did:

  1. Installed Backtrack 5 R3 on my machine.
  2. Installed CUDA support (Forceware <304) using these instructions:
  3. I downloaded oclhashcat-plus-0.09 and tried to run cudaHashcat. I got the message about requiring Forceware 304.
  4. I downloaded and installed nvidia Forceware 304.

I run cudaHashcat-plus and it seems to be working just fine. However, when I check the status, it throws a Seg Fault. It also throws a Seg Fault in the exact same place when it finishes and tries to output the status.

Here's what I see:

root@bt:~/Downloads/oclHashcat-plus-0.09# ./cudaHashcat-plus64.bin -m120 --hex-salt hash.txt /disk/words.lst
cudaHashcat-plus v0.09 by atom starting...

Hashes: 1 total, 1 unique salts, 1 unique digests
Bitmaps: 8 bits, 256 entries, 0x000000ff mask, 1024 bytes
Rules: 1
Workload: 128 loops, 80 accel
Watchdog: Temperature abort trigger set to 90c
Watchdog: Temperature retain trigger set to 80c
Device #1: GeForce GTX 560M, 1535MB, 1550Mhz, 4MCU
Device #1: Kernel ./kernels/4318/m0120_a0.sm_21.ptx

Scanned dictionary words.lst: 39099053676 bytes, 5343814622 words, 5343814622 keyspace, starting attack...

[s]tatus [p]ause [r]esume [b]ypass [q]uit => s
Status.......: Running
Input.Mode...: File (/disk/words.lst)
Segmentation fault
I am developing on exactly this driver version exactly with the same GPU (sm_21). Maybe you should try other OS.