salted md5
I would like to crack a hash which is md5(md5($salt).md5($pass)) with hashcat on my ATI Radeon graphics card.
I tried this:

hashcat-cli64.exe --attack-mode=3 --hash-mode=9 --output-file=out.txt --threads=1 --pw-min=4 --pw-max=12 --custom-charset1=abcdefghijklmnopqrstuvwxyz1234567890 hash.txt

but I didn't get any output, just this:

Usage: hashcat [options] hashfile [mask|wordfiles|directories]

Try --help for more help.

In hash.txt there is just one salted md5 (hash mode 9 is correct) in the format 32chars:8chars
What am I doing wrong?
you didn't supply a mask
thanks, now it's working. However I wanted to use oclHashcat-lite64.exe since it's faster but it seems like it's not working there:

D:\hashcat-gui-0.5.1\oclHashcat-lite>oclHashcat-lite64.exe --hash-type=1000 -o out.txt --pw-min=4 --pw-max=12 --custom-charset1=abcdefghijklmnopqrstuvwxyz XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:XXXXXXXX ?l?l?l?l?l?l?l?l?l?l?l?l?
ERROR: cannot read oclHashcat-lite.restore
Try to delete "oclHashcat-lite.restore" from *lite directory.
Your mask is also incorrect, you are using ?l instead of ?1 and you have a single ? on the end
I deleted oclHashcat-lite.restore, now I got this:
D:\hashcat-gui-0.5.1\oclHashcat-lite>oclHashcat-lite64.exe --hash-type=1000 -o out.txt --pw-min=4 --pw-max=12 --custom-charset1=abcdefghijklmnopqrstuvwxyz XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:XXXXXXXX ?1

'D:\hashcat-gui-0.5.1\oclHashcat-lite' is not recognized as an internal or external command,
operable program or batch file.

The md5 and salt doesn't have any special characters, just alphanumeric.
get some cmd crash course. You must not include the leading path. Also your mask is now totally fucked.
Sorry my bad. Now I get this:
oclHashcat-lite64.exe is not a valid Win32 application. Access is denied.
I'm running Win7 x64, but seems like I have to use oclHashcat-lite32.exe

btw is oclHashcat-lite even able to crack md5(md5($salt).md5($pass)) ?

When I use oclHashcat-lite32 I get this:
ERROR: invalid hash 'XXXXXXXXXXXXXXXXXXXXXXXXXXXXXXXX:XXXXXXXX'. double check -m parameter

Is the 5char length salt issue still a bug?
you are using the wrong hash mode. Have a look at --help
With issuing the previous command you deleted oclhashcat-lite64.exe (it is a 0 bytes file now). Redownload/extract the exe again.
I used oclHashcat-lite from hashcat-gui-0.5.1, but thats outdated. Now I downloaded oclHashcat-lite-0.10 where oclHashcat-lite-64 is running fine.