BSOD with 7970

I just bought a MSI 7970 OC Boost.
I did a clean format and reinstall of windows.
Now, each time I launch oclhashcat, it makes a BSOD Sad
Win 7 x64 + Catalyst 13.1.

I did some checks, BSOD is caused by the driver atikmpag.sys :
Quote:On Sat 19/10/2013 17:30:10 GMT your computer crashed
crash dump file: C:\Windows\Minidump\101913-31309-01.dmp
This was probably caused by the following module: atikmpag.sys (atikmpag+0x9410)
Bugcheck code: 0x116 (0xFFFFFA80073314E0, 0xFFFFF88004E09410, 0x0, 0x2)
file path: C:\Windows\system32\drivers\atikmpag.sys
product: AMD driver
company: Advanced Micro Devices, Inc.
description: AMD multi-vendor Miniport Driver
Bug check description: This indicates that an attempt to reset the display driver and recover from a timeout failed.
A third party driver was identified as the probable root cause of this system error. It is suggested you look for an update for the following driver: atikmpag.sys (AMD multi-vendor Miniport Driver, Advanced Micro Devices, Inc.).
Google query: Advanced Micro Devices, Inc. VIDEO_TDR_ERROR

Any ideas to solve my problem ?

Thank you very much.

PS : GPUZ screenshot :
Using quality operating system would solve a lot of problems including this one.
To test, I replace the 7970 with my (former) 5870 : oclhashcat works.

So in my opinion it's not a problem regarding to the OS.

- should I update something concerning the drivers to get the 7970 run ?
- do you think it's a problem linked to the card itself and I should contact the seller ?

have you tried a newer driver?
I have tried the latest 13.9, but oclhashcat crashes as this is not the -exact- 13.1.
Are you using oclHashcat-plus or oclHashcat-lite?
The recommended driver version for oclHashcat-plus is 13.4, but 13.8 and 13.9 seem to work also without problem here.
If you use lite and have 13.9 installed then --force *might* work, although *not* recommended nor supported.

Also, it is possible that this could help: (i.e. uninstall AND use driver fusion + remove all opencl.dll libraries from your system).

Also you should use latest version of oclHashcat-lite/oclHashcat-plus (if not already done).
Thanks for the answer.

Indeed I only use ocl-plus 0.15, so I don't need 13.1 anymore.

- I completely uninstall AMD drivers thanks to Programs, DriverFusion, and amd_cleanup_util_1.2.1.0.exe.
- I install Catalyst 13.9 (latest) for 7970. Reboot.
- oclhashcat-plus 0.15 test : OK
- oclhashcat-lite 0.15 test : benchmark crash (at Joomla hash)

Thank you so much Smile
segfaulting on joomla with lite and newer drivers is expected. don't worry, lite will soon be gone.
No problem I'll wait =)