clEnqueueReadBuffer() -30
What does this error mean? It seems to be related to only 1 of my GPUs. It happens on Windows7 64bit, catalyst 13.8b1, oclhashcat b19.

clEnqueueReadBuffer() -30
#define CL_INVALID_VALUE -30

might be a bug, can you reproduce it?
(11-11-2013, 04:31 PM)atom Wrote: #define CL_INVALID_VALUE -30

might be a bug, can you reproduce it?
I had it for -m 2711. I rebooted in case it was a driver that crashed. It was still there. I switched to other attacks and it was fine so far. When my attacks will be finished, I will try again on -m 2711.
I am also getting the same error with both 2711 and 2611, on both rule based and combination attacks. I have not gotten around to testing other m values, but it does take about 10-20 minutes into an attack before the error appears. I am running the standard Ubuntu 12.04 LTS x64 build, 3.5.0-42 kernel with catalyst 13.11 beta 6 drivers, oclhashcat 0.15.

On one of my tests, instead of the clEnqueueReadBuffer() -30 error I got a message that said hashcat could not flush the password buffer, or something to that effect. Unfortunately I never wrote the exact phrase down, but every other time I got the clEnqueueReadBuffer() -30 error. I also tried rebooting but it still happened at the same place during the same attacks.

I'm guessing mastercracker is already on the case as a beta tester, but let me know if I should submit a trac request.
not accepting error reports from

catalyst 13.11 beta 6

the worst driver ever.

do not use it, its known to be broken and i warned couple of times
i got same issue in 13.4 driver. both Times when working on vb4 yesterday it was first time, today second and i did not change anythink in os (win7 home prem 4x7970)
was it a multihash list and it was cracking something?
yes it was list, 5minutes ago i got same isue on second rig (3x7970) there was 705 hashes file, in my 4x7970 list got about 200 hashes. In both case that was only one hashcat instance running in one time
OK, this might be a fixed bug of current v0.15 version. With oclHashcat v1.00 it should not happen. If you want you can test it with oclHashcat v1.00 beta version. Send me an email if you want to be added as beta tester.