R9 M200 series compatibility
#1
I am currently in the process of scouting new laptops to use for school/pentesting as a hobby/education. I need a laptop because I need to be able to haul it to lab twice a day 5 days a week so a desktop is out of the question but I would like to have the ability to play around with oclhashcat as it seems like an awesome tool and has me very interested. I have found a Toshiba on sale with a lot of ram and an i7 4710hq (not so worried about battery life) and I believe it is the one. A big bonus is that it does have a dedicated GPU. Its not the best but I don't plan on gaming with it, although i would like to utilize it with oclhashcat if possible. I have read and read all the resources that I can find about this GPU on this forum and others and I cant seem to find if it is compatible or not. I have found that AMD does provide a catalyst 14.9 driver for it but upon following the link for OpenCL AMD compatible cards, I can not find it.
The card that I'm looking for is the AMD R9 M265X.

There is a R7 M240 as well as the R9 290 and R9 290X (obviously) on the AMD OpenCL compatibility link but not the card i am looking for. I know that the M series cards are not as common but the fact that there is at least one on there gives me hope. Should I assume that it works because it is a new card in the R9 series or should I assume it does not run with OpenCL because it is not on the AMD OpenCL page? Is there any other way for me to verify the compatibility or lack there of on the R9 M265X? I know that it is supported by Catalyst 14.9, but I am not sure that OpenCL will run on it. Can I check its chip set against the regular R9 series to determine compatibility? You guys seem to have a lot of knowledge on the subject- Help! I need a hardware guru.

PS- here is the link I was referring to that I followed from the beginning of the hardware forum discussing compatibility:

http://developer.amd.com/tools-and-sdks/...atibility/

Thank you very much for your time. It is very appreciated!

----UPDATE----
I have found an OpenCL 2.0 Driver that says that it is compatible with the R9 m200 series at this link:

http://drivers.softpedia.com/get/GRAPHIC...-bit.shtml

Now my question is this: Dose this mean my card is compatible as they offer Catalyst 14.9 and OpenCL 2.0 drivers? An issue I see is that the link with the drivers says Catalyst 14.41. I guess I am confuse about the difference between catalyst and OpenCL. Is there a difference and I need both, or are they the same thing, and if so, will I have to wait until OCLHashcat becomes compatible with a later version of Catalyst? Sorry for all of the question.
Reply
#2
I don't quite get your problem. You need the 14.9 driver which you find here:
http://support.amd.com/en-us/download/de...4&rev=14.9

It contains the right OpenCL driver too. Do not download driver from 3rd party sites unless you have absolutely no other chance.

OpenCL 2.0 is beta and not usable yet.
Reply
#3
so i must have confused myself- if the card has compatibility with catalyst 14.9 then it is OpenCL compatible and will work?
Reply
#4
Yep - just try it.
Reply
#5
awesome! i am going to buy the laptop tonight. ill let you know how it works. thanks for your time!
Reply