hash issues
Hi all,
Having issues getting cudahashcat to love me, an approximation of my hash is below, along with the corresponding error message.

the hash is from the first : (colon), to the next one, the $1$ I would think is -m 500, but l've also tried 20, 1500 or anything else I can think of.. It's a slax root pwd on a penetration practice disk..

Any help/advise appreciated greatly...

this is root.hash..


cudahashcat64 -m 500 -a0 root.hash /root/dict/rock410.txt -o recovered.txt
cudaHashcat v1.31 starting...

WARNING: Hash 'root.hash': Signature unmatched

ERROR: No hashes loaded
cudahashcat64 -m 500 root.hash /root/dict/rock410.txt -o recovered.txt
Still gives me signature unmatched - no hashes loaded
and I haven't got any leading or trailing spaces...
Ran the same through hashcat rather than cudahashcat64... and it worked... what would be the difference?? have run cudahashcat64 on wpa passwords with success, any ideas anyone? thanks
You need to specify the correct path to the file "root.hash".

On linux for instance you can use tab-completion or use "ls" to check if the file really exists at the location you think it exists.

For instance this:
WARNING: Hash 'root.hash': Signature unmatched

... means:
"I was unable to find the file 'root.hash' within the current working directory, I did try to parse the parameter 'root.hash' as a hash directly, but this didn't work either because the string 'root.hash' is not a valid md5crypt hash"

In other words oclHashcat/cudaHashcat whenever it fails to find the hash file specified on command line, it tries to parse the command line as hash directly (while hashcat cpu does not).

Solution: fix the path to the hash file (best for testing is to use absolute paths, e.g starting with /... , but relative paths work too if you know the exact (relative) position)
Thanks I'll give it a go..
I think that's solved... awesome, thanks philsmd.. much appreciated, nice to be able to use the gpu..