Under The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali): Error - X needs to be running...
This isn't directly a HC issue, but I'm hoping someone can make sense of it that is more familiar with the ATI drivers than myself.

I picked up some cheap GPUs and was going to benchmark them with some other cheap hardware I picked up. Not having a spare HDD I decided I would just do a full distro install on a flash drive and since I already had Live The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) 1.1.0a flash drive laying around I figured I would use it to install The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) as a full install on an empty flash drive.

There is a guide on how to install Catalyst on The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali), but it uses packages and it doesn't reference the driver version, so I didn't want to waste my time cluttering up the drive with packages with it likely being the 14.9 drivers.

Instead I just ran the commands referenced in the wiki here to fetch and install Catalyst. It all went mostly good, and even though it said the driver was installed successfully it also said check the log for errors.

The error was it failed to build fglrx against DKMS. I could be mistaken, but I thought DKMS is not explicitly required for it run.

So I go ahead and do:
aticonfig --adapter=all --initial -f

Instead of bringing up the The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) (gnome based) login it goes straight to console now. So I deleted the xorg.conf it created and rebooted.

The gnome desktop starts up as it should now, but when I:
aticonfig --adapter=all --odgt
It tells me that it is not configured, run aticonfig --initial.

I do that (knowing when I reboot it won't start the gnome desktop), and checkout the file and it all looks right and detected all 3 GPUs.

I then try to get the temp again and it tells me the X server is not running. Clearly this isn't the case since I'm using a gnome desktop X has to be running. Just for grins when I /usr/sbin/Xorg it tells me the Server is already active on display 0.

When I run fgl_glxgears I'm only getting 95 frames per second on the animation, so something is wrong there also.
fglrxinfo tells me my display is :0.0 and screen is 0.
I tried exporting the DISPLAY variable with ":0", ":0.0" "0", etc as well to prevent the error.

Oh... I almost forgot... when installing Catalyst it seems to overwrite libGL.so.1 with the 32 bit version even though it detects my arch as 64. I believe this might be why the installs fails with DKMS based on the logs.

After installing Catalyst if I run fglrxinfo I get an error about that lib having ELFCLASS32. I have to fix it by reinstalling libgl1-mesa-glx
and run ldconfig

After doing those two things fglrxinfo works.

While I'm at it, does anyone know of a setup guide working The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) 1.1.0 for installing Catalyst 14.9 (oclHC compatible)? Installing working packages would probably be quicker to deploy than trying to troubleshoot this. But seeing as there probably isn't since I couldn't find one if anyone has some tips on how to Xorg.conf to run the desktop and aticonfig doesn't think X is running that would great.

I could probably save some heartache by installing a different distro but there are reasons why I need it running under The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) long term than just it being something I already had on hand.

Not that is matters but the GPUs are a Radeon 5970 and 5870. aticonfig detects all 3 cores in the Xorg.conf (which for whatever reason prevents gnome from launching on reboot).

I have no problem with these cards on Windows using the win binaries. I would just run them there but the reason for wanting to put them under The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) is I'm writing code to automate oclHC with some of the other tools in the The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) distro.

I could always just do a Ubuntu install or something if that is the defacto distro for running ATI drivers without a hitch, but I would prefer to get the drivers working under The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) with the Gnome desktop.

Note: After digging a little more, it seems like maybe ATI drivers don't play nicely with gnome. Is anyone here using them with gnome and if not what desktop do you run on your linux rigs?

Just to followup on this... I was able to figure out why the ATI installer was throwing errors about DKMS.

The installer needed patched to work with kernel 3.17 and up. I applied the patch and that gave me a successful build.

However, when the installer finishes it tries to run aticonfig --initial and it threw the same ELFCLASS32 error (meaning the damn thing overwrote libgl1 again with a 32 bit version. I purged out the mesa-glx package and reinstalled to get the 64 bit in there.

Then aticonfig runs fine and builds the xorg.conf as usual. At this point I'm hoping for success, but X will still not start with Xorg.conf config. It just says Fatal Server Error: no screens found

So I look in the xorg log and the problem is when it gets to LoadModule fglrx it says says "Couldn't open module fglrx... failed to load module fglrx (module does not exist, 0)"

So I don't know what is going and why I can't the driver working at this point. I even removed gnome and installed XFCE since I read gnome has issues with the ati driver, but its not even getting to the point where it loads a DM, it can't even start X.

Any thoughts? I already made sure the boot load wasn't using nomodeset.

I've been at this for a couple days with no luck and have google'd to hell and back and tried no less than 50 different things. At this point the package manager is all fuxord anyways so I'm over it. I'm going to throw in the towel but it if anyone knows for future reference how to get The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) 64 bit running with oclhc please advise. I am going to install regular Ubuntu and go from there. I found one post that mentions The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) 32 bit can work, but I'm going to go through the hassle of trying with the chance it might not, and although I wouldn't imagine 32 bit would be slower performance on the GPUs I'm not 100% sure on that either so that is another reason I'm not going to try right now.

Just FYI... Ubuntu 14.04.2 Desktop doesn't appear to work either. I figured it would since the Wiki reference the server edition of the same version. But according to AMD they only support Xorg up to 1.15 on 14.9 and Ubuntu ships with Xorg 1.16.0.

I'm going to switch to Xubuntu 14.02 (.0) and see how that goes since apparently Gnome has been reported to by some to cause issues with 14.9 too.

I need a desktop version for this install and it is turning into a major PITA. Just FYI... the error from Xorg log is because it is trying to load the module "glx" and libglx.so has an undefined symbol.

What a mess it is to get exactly 14.9 installed under linux. I wish I could these GPUs on windows but it just isn't an option.

Welp, I thought I was golden with a fresh install of Xubuntu 14.04... the installer ran without error (just like on Ubuntu 14.04.02), but upon reboot it actually booted into X and the resolution was nice, so clearly it was running a new driver.

aticonfig --lsa
shows all of my GPUs, so I thought I was golden, but no...

aticonfig --adapter=all --odgt
ERROR - OD Get Version failed

X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 157 (ATIFGLEXTENSION)

oclHashcat.bin -b
modprobe: FATAL: Module fglrx not found

I looked inside of Xorg.0.log and it doesn't show any errors and fglrx is logged a bunch in there and says it is loaded.

This is the 3rd fresh full OS install I've done and no matter what I've tried I can't get the 14.9 drivers to work.

I tried with The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) 1.1.0a (64), Ubuntu LTS 14.04.02 (64), Xubuntu 14.04 (64)... all produce errors.

FYI for anyone in a similar position. On Xubuntu I clicked on Additional Hardware in settings and saw it was set for ATI/AMD Xorg wrapper. Now this might be what it should say since I installed the drivers from the AMD installer and not using a apt-get package (since that wasn't the right driver version).

I switched it to the "proprietary fglrx driver". It took a while for the settings to apply which led me to believe after the fact it might be downloading a package.

When I reboot it would try to overwrite my xorg.cnf file each time, so I had to comment out some lines in /etc/init/gpu-manager.conf. After that it stopped overwriting my xorg.cfg so I could keep what was written by aticonfig --adapter=all --initial

That allowed me to see all 3 GPUs, set the fan speeds and get temp readings.

The strange thing is HC complains it is not the right driver, but when I do fglrxinfo it says I'm using
Compatibility Profile Context 14.301.1001
and that matches the 14.9 Catalyst installer.

I use the --force option get it to run and it is running a top speed and performs all benchmarks and some of my own tests without a problem so far.

Either I do have the right driver but HC is looking elsewhere and seeing something different or I do in fact have the wrong driver, but if it is the latter it sure is running good with it which would be surprising.
Hashcat looks at the OpenCL library version (as that's what matters.) What does clinfo say?
Driver Version: 1729.3
Version: OpenCL 1.2 AMD-APP

I probably spoke too soon about everything running fine... when I pushed for a longer period the machine would freeze, or at least X. Screen frozen and mouse and keyboard unresponsive... cycling power was the only option, could not switch to a shell either.

I'm guessing I have the wrong driver since HC is complaining. I don't know why it is being difficult to get 14.9 installed. On older headless installs I haven't had a problem. It is just trying to get it installed under desktop distro is just doesn't want to cooperate.

I'll probably end up just setting it up headless too, but I wanted to use this machine for actual desktop use as well as being able to cluster with the headless rig.
Yeah, that's the wrong version. For 14.9, the correct version is 1573.4. So you definitely have a much newer driver installed than 14.9.

I'm sorry you're experiencing so many difficulties. I haven't chimed in on your issues because I have no experience doing desktop installs, only headless installs. I'm rather surprised though that the WM/DM would cause so many issues.
No worries, I'll figure it out eventually. I see they have Ubuntu packages available for 14.9 on the Jessie repo. I will see if I can get that one installed without a lot of fuss. For whatever reason compiling from installer just isn't going smoothly.