Trying to get "Hybrid dict + mask" to work
Hi everyone,

I'm not really into cracking to be honest...

I'm currently on a Windows 10 machine and trying to get a decent result with this:
cudaHashcat64.exe -a 6 -o cracked.txt -m 0 hash.txt wordlist.lst rockyou-7-2592000.hcmask --status

The result:
Device #1: GeForce GTX 970, 4096MB, 1304Mhz, 13MCU
Device #1: WARNING! Kernel exec timeout is not disabled, it might cause you errors of code 702
          You can disable it with a regpatch, see here:

Hashes: 1 hashes; 1 unique digests, 1 unique salts
Bitmaps: 16 bits, 65536 entries, 0x0000ffff mask, 262144 bytes, 5/13 rotates
Applicable Optimizers:
* Zero-Byte
* Precompute-Init
* Precompute-Merkle-Demgard
* Meet-In-The-Middle
* Early-Skip
* Not-Salted
* Not-Iterated
* Single-Hash
* Single-Salt
* Scalar-Mode
* Raw-Hash
Watchdog: Temperature abort trigger set to 90c
Watchdog: Temperature retain trigger set to 80c
Device #1: Kernel ./kernels/4318/m00000_a1.sm_52.64.cubin
Device #1: Kernel ./kernels/4318/markov_le_v4.sm_52.64.cubin

Cache-hit dictionary stats wordlist.lst: 56620403 bytes, 5014858 words, 5014858 keyspace

 The wordlist or mask you are using is too small.
 Therefore, oclHashcat is unable to utilize the full parallelization power of your GPU(s).
 The cracking speed will drop.

INFO: approaching final keyspace, workload adjusted

Session.Name...: cudaHashcat
Status.........: Exhausted
Input.Left.....: File (wordlist.lst)
Input.Right....: Mask (rockyou-7-2592000.hcmask) [24]
Hash.Target....: 43a431f5512b1daad3faa33a68bd50a5
Hash.Type......: MD5
Time.Started...: 0 secs
Time.Estimated.: 0 secs
Speed.GPU.#1...:   865.7 MH/s
Recovered......: 0/1 (0.00%) Digests, 0/1 (0.00%) Salts
Progress.......: 5014858/5014858 (100.00%)
Rejected.......: 1713/5014858 (0.03%)
HWMon.GPU.#1...:  1% Util, 36c Temp, 797rpm Fan

Started: Thu Nov 26 01:07:35 2015
Stopped: Thu Nov 26 01:07:36 2015

Why does it say "The wordlist or mask you are using is too small."?
What am i doing wrong >_<

Thanks in advance,

it obviously works perfectly fine.
You only have about 5 million hashes to check through, and the hashing method means your gpu can get through 865.7MH/s, or 875.7 million hashes per second.

So you're only taking about 0.07 of a second to complete this task, which is why it gives you the message that your wordlist is too small, given the speed that your gpu is going. It's still checking through all the hashes, as you can see by the 100% progress, just giving you a heads-up that you might want to use a larger list next time.
So why does it not find "f30aa7a662c728b7407c54ae6bfd27d1" which is md5 for "hello123"?
My Wordlist oviously contains "hello", so shouldn't the mask do the number-things?

(Doesn't work with --increment either)

Thanks for the info Smile
Hmm okay three things:
1) Are you sure that "f30aa7a662c728b7407c54ae6bfd27d1" is in your hash file? cudaHashcat seems to only pick up 1 hash within the file which is "43a431f5512b1daad3faa33a68bd50a5".
2) Are you sure that your wordlist contains the word 'hello'?
3) Are you providing the correct path to the mask file?
(the default location for the mask file relative to the cudaHashcat executable is masks/rockyou-7-2592000.hcmask)
Try replacing the mask file in the command line with ?d?d?d and see if it manages to pick up 'hello123'.
Quote:What am i doing wrong >_<

You're trying to crack 43a431f5..., not f30aa7a6... (hello123).

Quote:Hash.Target....: 43a431f5... etc.
@rico the hash in the code above is an old one, tried it with the new "f30aa7a6.." one. The "43a431f5.." was something different obviously Smile

@wrigglingears yes i'm sure. (See above).
2) yep, double checked it Smile
3) already tried changing the path.. Sad
4) thanks, will try this when i'm home, but shouldn't this be included in rockyou?

(11-26-2015, 02:19 AM)NeoXen Wrote: Input.Right....: Mask (rockyou-7-2592000.hcmask) [24]
Hash.Target....: 43a431f5512b1daad3faa33a68bd50a5

look at that mask from your output. It tries to use the path as a mask, because the file could not be found.

Try this instead:
cudaHashcat64.exe --status -m 0 -a 6 -o cracked.txt hash.txt wordlist.lst masks\rockyou-7-2592000.hcmask

The output should look like this then:
Input.Right....: Mask (?d) [1]
Hash.Target....: 43a431f5512b1daad3faa33a68bd50a5

it will change to Mask (?d?d) [2], Mask (?l) [1], Mask (?d?d?d?d) [4] etc
If this is not the case, it is true what wrigglingears said, that the path is not correct and cudaHashcat tries to use the parameter as a directly specified mask on the command line (instead of the .hcmask file).