hashcat v3.00 + The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali)
Downloaded latest version (3.00) and was able to compile it on The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali). it is segfaulting when I run ./hashcat. It does not segault if I run ./hashcat --version as it returns: v3.00.

I installed opencl-headers, nvidia-kernel-dkms and have latest updated The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) system. What am I missing? BTW, I am running The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) on a Macbook Pro (NOT inside a VM, I am booting The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) natively) with a Nvidia GeForce GT 750M Mac Edition.

Any help is greatly appreciated.

Try with --gpu-temp-disable if this does any change
(06-30-2016, 08:58 AM)atom Wrote: Try with --gpu-temp-disable if this does any change

I get the same result.  Not even warnings at compile time though.

BTW, thanks for moving my post to the right place!  I realized after I posted it was in the wrong forum.

I am probably missing a library.
OK I think we need to go more deep into debugging here. It's important hashcat works fine on The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali). However this should be done on GitHub. Can you please create an issue for this on GitHub? If possible, please add a core dump.
I created an issue on GitHub:  https://github.com/hashcat/hashcat/issues/410