NvAPI_GPU_GetThermalSettings() -1 NVAPI_ERROR
#1
Hi,

Please could you help me with the following.

My setup:

Card: NVIDIA GTX 970M
Drivers (latest): 368.81
OS: Windows 10 64bit
Hashcat: cudaHashcat-2.01

Attempting to crack Cisco passwords using the following command:

Quote:cudaHashcat64.exe -m 2400 hashes.txt

CudaHaschat runs shortly, recovers one hash before repeatedly displaying the following error:

Quote:NvAPI_GPU_GetThermalSettings() -1 NVAPI_ERROR


After doing this a few times, the machine crashes and shutsdown.

Any suggestion is appreciated.
#2
Please use hashcat v3.00 or higher
#3
(08-12-2016, 03:25 PM)atom Wrote: Please use hashcat v3.00 or higher

Hi Atom,

Thanks for your reply, I tried Hashcat v3.10 and I received the following error, again using the latest Nvidia drivers too.

WARN: NvAPI_GPU_GetPerfPoliciesInfo() -1 NVAPI_ERROR
WARN: NvAPI_GPU_GetPerfPoliciesStatus() -1 NVAPI_ERROR

I receive the above a number of times before my machine crashes.

Thanks
#4
Update:

By adding the following to my command:

--gpu-temp-disable

NVAPI errors have disappeared whilst running Hashcat v3.10, however if a large dictionary is used I get a BSOD got a driver error. Also, if I hit CTRL + C to cancel hashcat, my machines dies.

Any thoughts?
#5
Update:

When trying a small dictionary, when Hashcat reaches "Exhasted" laptop freezes and machine switches off.

Is there a log file I can check that reveals more information?

Thanks
#6
propably overheating problem, try to set your fans to 100% before starting hashcat
#7
(08-31-2016, 01:57 PM)atom Wrote: propably overheating problem, try to set your fans to 100% before starting hashcat

That makes sense, but this being a laptop is there way to set the fans at 100%? The options to change the fan speed is greyed out on the Nvidia Control Panel and third party products such Afterburner, Precision X and Thunder Master.

Having looked in the BIOS I cannot see any options to do with the GPU fan speed.

Example screenshot attached.

Thanks.


Attached Files
.png   fan speed greyed out.PNG (Size: 28.84 KB / Downloads: 9)
#8
I don't know of any.
#9
Hi all,

Bit of an old thread, thought it was only right to provide you with an update, the following command worked for me and no system crashes after running it multiple times on both dictionaries and rules. Only tried it for Oracle hashes, but will keep this thread updated if it changes for other hash types:

Using: Hashcat 3.30 64bit exe

Platform: Windows 10 (fully updated as of early Feb 2017)

Nvidia drivers:

NVIDIA Graphics Driver 378.49
NVIDIA GeForce Experience 3.3.0.95

Theme:

Optimize the Windows 10 theme for performance (untick all of the boxes under the System functionality)

Hashcat command:

hashcat64.exe -m 3100 --opencl-device-type 1,2 -d 2 hashfileheere dictionaryfilehere -o outputfilehere

Hope the above helps Smile
#10
Maybe the driver update solved your issues