Need help with mask attack on OSX
Hey there. 

For several days now I try to solve a geocaching puzzle (which I'm almost certain uses a sha1 hash) with the help of hashcat but all I can get is "Exhausted" as a result. 

Can you tell me what I am doing wrong please?

So this is my command (of with I already tried dozens of variations):
hashcat -m 100 -a 3 -o found.txt --custom-charset1=5678 --custom-charset2=123456 sha-1.txt "N 49 2?1.?d?d?d E 011 0?2.?d?d?d" --potfile-disable

In sha-1.txt is a single line with this hash:

And that is the result:
OpenCL Platform #1: Apple              
- Device #1: Intel(R) Core(TM) i7-3615QM CPU @ 2.30GHz, skipped
- Device #2: HD Graphics 4000, 384/1536 MB allocatable, 16MCU
- Device #3: GeForce GT 650M, 128/512 MB allocatable, 2MCU

Hashes: 1 digests; 1 unique digests, 1 unique salts
Bitmaps: 16 bits, 65536 entries, 0x0000ffff mask, 262144 bytes, 5/13 rotates
Applicable Optimizers:
* Zero-Byte
* Precompute-Init
* Precompute-Merkle-Demgard
* Early-Skip
* Not-Salted
* Not-Iterated
* Single-Hash
* Single-Salt
* Brute-Force
* Raw-Hash
INFO: approaching final keyspace, workload adjusted      

Session.Name...: hashcat
Status.........: Exhausted
Input.Mode.....: Mask (N 49 2?1.?d?d?d E 011 0?2.?d?d?d) [24]
Custom.Chars...: -1 5678, -2 123456, -3 Undefined, -4 Undefined
Hash.Target....: 0e9bfe8f349ed4b75d480743d1ab55e6e83c8176
Hash.Type......: SHA1
Time.Started...: Mon Sep 19 17:49:30 2016 (1 sec)
Speed.Dev.#2...:  3268.8 kH/s (10.22ms)
Speed.Dev.#3...: 18382.9 kH/s (0.09ms)
Speed.Dev.#*...: 21651.7 kH/s
Recovered......: 0/1 (0.00%) Digests, 0/1 (0.00%) Salts
Progress.......: 24000000/24000000 (100.00%)
Rejected.......: 0/24000000 (0.00%)

Started: Mon Sep 19 17:49:30 2016
Stopped: Mon Sep 19 17:49:35 2016

All I can seem to get is "Exhausted" status even if I change the mask, post the hash directly into the command, use a .hcmask file and so on. Is there an error in my command – or is something wrong with the OSX implementation?

Thanks and regards!
"Exhausted" mean that all combinations of given charset was checked with no match (in other words job done 100% and password didnt found )
(09-20-2016, 12:42 PM)Szulik Wrote: "Exhausted" mean that all combinations of given charset was checked with no match (in other words job done 100% and password didnt found )

But it can impossibly be done in 5 seconds ... or can it?
The keyspace is only 24000000.
(09-20-2016, 07:42 PM)Xanadrel Wrote: The keyspace is only 24000000.

As I am quite new on this: What does this actually mean? Is my mask wrong?
it means that for this hash 24,000000(24 mil) is nothing while u do 21651.7K (u finished the attack in 5 sec..)
hashcat tried all the 24mil "passwords*" and did not find any that belong to that hash