Detection of multiple CPU
#1
If you have OpenCL runtime installed and have two of the same processors, does hashcat report both separately?

When I run hashcat -I, the CPU section is:

Code:
Platform ID #1
 Vendor  : Intel(R) Corporation
 Name    : Intel(R) OpenCL
 Version : OpenCL 1.2 LINUX

 Device ID #1
   Type           : CPU
   Vendor ID      : 8
   Vendor         : Intel(R) Corporation
   Name           : Intel(R) Xeon(R) CPU E5-2630 v3 @ 2.40GHz
   Version        : OpenCL 1.2 (Build 25)
   Processor(s)   : 32
   Clock          : 2400
   Memory         : 16077/64309 MB allocatable
   OpenCL Version : OpenCL C 1.2
   Driver Version : 1.2.0.25


However I have two of the same CPU. If I do a cat /proc/cpuinfo, I see all 32 CPU represented correctly. 

If I run a benchmark, it shows the same OpenCL device output which makes it seem as if it is using a single CPU chip. However I didn't know if maybe OpenCL was just reporting both CPUs as the same device? 

Code:
hashcat --opencl-platform=1 -b
hashcat (v3.40-49-g20057d8) starting in benchmark mode...

OpenCL Platform #1: Intel(R) Corporation
========================================
* Device #1: Intel(R) Xeon(R) CPU E5-2630 v3 @ 2.40GHz, 16077/64309 MB allocatable, 32MCU

OpenCL Platform #2: NVIDIA Corporation, skipped or no OpenCL compatible devices found

Hashtype: MD4

Speed.Dev.#1.....:  2077.8 MH/s (15.95ms)

Hashtype: MD5

Speed.Dev.#1.....:  1334.5 MH/s (24.85ms)
Reply
#2
Wow I'm an idiot. Just noticed the line which cleared says 32 processors. :-D

Processor(s) : 32
Reply
#3
Yeah. OpenCL only exposes one CPU "device" to the application that represents all physical and logical processing cores. It's actually much better that way, very smart way to do it.
Reply