RX Vega + Ubuntu 16.04.3 = no OpenCL
Having an issue getting hashcat to work with fresh install of Ubuntu 16.04.3. Installed the supported AMD drivers (amdgpu-pro-17.30-465504) and am completely unable to run hashcat. See error and details below:

uname -a
Linux cpupirate-Miner01 4.10.0-32-generic #36~16.04.1-Ubuntu SMP Wed Aug 9 09:19:02 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

lsb_release -a
No LSB modules are available.
Distributor ID:    Ubuntu
Description:    Ubuntu 16.04.3 LTS
Release:    16.04
Codename:    xenial

dpkg -l amdgpu-pro
ii  amdgpu-pro                           17.30-465504            amd64                   Meta package to install amdgpu Pro components.

./hashcat64.bin -b
hashcat (v3.6.0) starting in benchmark mode...

/home/hashcat/OpenCL/: No such file or directory

Segmentation fault (core dumped)

In this setup the GPU does display the screen however I have the onboard enabled as I plan to run this headless as a miner and pw cracking rig. I tried installed the driver with the --compute option as well with the same result.
Adding an update, doesnt appear to be limited to Hashcat, looks like its OpenCL as a whole at the moment. Still looking for answers but trouble shooting the overall recognition issue for the card now.
Yeah, I've been banging my head off the desk for a few hours on this as well. opencl just isn't seeing the card. Remainder of the driver appears to be working fine, glx/dri etc. Tried with ROCm and amdgpu-pro.

Does partially work in windows. Some tests fail and eventually the system locks up on win 10.
I don't know if you are new to Linux so forgive me if you have already done all this, but did you try to download the source and build locally?

Open a terminal and create a build directory and then cd into that directory.
mkdir /home/YOUR_USER_NAME/hashcat
cd /home/YOUR_USER_NAME/hashcat

You might need to install git before the following will work.
sudo apt-get install git

Then type the following commands:
git clone https://github.com/hashcat/hashcat.git
cd hashcat

git submodule update --init

Then you can try running it before installing it:
./hashcat -b

I can't remember if there are any dependencies that I needed to download with apt-get. Anyway, try the above and get back to me.