Restore Fails
#1
For the last couple of weeks I have noticed hashcat failing to restore a session. The error I seem to get is 
Quote:Restore value is greater than keyspace
. I have been running hashcat for a day or two, so having to restart is annoying.

When I stop hashcat I use checkpoint 'c' so I am not sure what I am doing wrong. I have been using 3.6.
Reply
#2
It's fixed with v4.0.0
Reply
#3
I am now on 4.0.0 and having the same issue.
Reply
#4
It is (but not with a .restore file written from v3.6).
Reply
#5
I have same problem (hashcat 4.0.1), no restore
when use the command line:
hashcat64 -m 2500 -a 3 mio.hccapx -1 ?l?d ?1?1?1?1?1?1?1?1 --session=save -w 3 -D 1,2
Is working fine but if I try to use --restore:
hashcat64 -m 2500 -a 3 mio.hccapx -1 ?l?d ?1?1?1?1?1?1?1?1 --restore --session=save -w 3 -D 1,2

result:
Z:\Proyectos\BruteForce Pass Cracking\hashcat-4.0.1>hashcat64 -m 2500 -a 3 mio.hccapx -1 ?l?d ?1?1?1?1?1?1?1?1 --restore --session=save -w 3 -D 1,2
Usage: hashcat64 [options]... hash|hashfile|hccapxfile [dictionary|mask|directory]...

Try --help for more help.

Z:\Proyectos\BruteForce Pass Cracking\hashcat-4.0.1>pause
Press any key to continue . . .

Hope u tell what I'm doing wrong sorry for may ignorance
Reply
#6
Does this work:


hashcat64 -m 2500 -a 3 mio.hccapx -1 ?l?d ?1?1?1?1?1?1?1?1 --session save -w 3 -D 1,2

hashcat64 -m 2500 -a 3 -w 3 -D 1,2 --session save --restore
Reply
#7
No, that's also not 100% correct.

The FAQ (https://hashcat.net/wiki/doku.php?id=fre..._questions) already says that "The only parameters allowed when restoring a session are --restore and --session (optional)"

so the command should be just:
Code:
hashcat64 --restore --session save
Reply
#8
Can you try your self pls, because to none of the following combination are working:
hashcat64 -m 2500 -a 3 mio.hccapx -1 ?l?d ?1?1?1?1?1?1?1?1 -D 1,2 --restore --session save

or this

hashcat64 -m 2500 -a 3 mio.hccapx -1 ?l?d ?1?1?1?1?1?1?1?1 -D 1,2 --session save --restore

or this

hashcat64 -m 2500 -a 3 mio.hccapx -1 ?l?d ?1?1?1?1?1?1?1?1 --restore --session save

or this

hashcat64 -m 2500 -a 3 mio.hccapx -1 ?l?d ?1?1?1?1?1?1?1?1 --session save --restore


I always get the same result:

Usage: hashcat64 [options]... hash|hashfile|hccapxfile [dictionary|mask|directory]...
Try --help for more help.
Z:\Proyectos\BruteForce Pass Cracking\hashcat-4.0.1>pause
Press any key to continue . . .




(12-29-2017, 09:17 AM)philsmd Wrote: No, that's also not 100% correct.

The FAQ (https://hashcat.net/wiki/doku.php?id=fre..._questions) already says that "The only parameters allowed when restoring a session are --restore and --session (optional)"

so the command should be just:
Code:
hashcat64 --restore --session save
Reply
#9
here you have the hccapx

(12-29-2017, 07:53 PM)hardwarematik Wrote: Can you try your self pls, because to none of the following combination are working:
hashcat64 -m 2500 -a 3 mio.hccapx -1 ?l?d ?1?1?1?1?1?1?1?1 -D 1,2 --restore --session save

or this

hashcat64 -m 2500 -a 3 mio.hccapx -1 ?l?d ?1?1?1?1?1?1?1?1 -D 1,2 --session save --restore

or this

hashcat64 -m 2500 -a 3 mio.hccapx -1 ?l?d ?1?1?1?1?1?1?1?1 --restore --session save

or this

hashcat64 -m 2500 -a 3 mio.hccapx -1 ?l?d ?1?1?1?1?1?1?1?1 --session save --restore


I always get the same result:

Usage: hashcat64 [options]... hash|hashfile|hccapxfile [dictionary|mask|directory]...
Try --help for more help.
Z:\Proyectos\BruteForce Pass Cracking\hashcat-4.0.1>pause
Press any key to continue . . .




(12-29-2017, 09:17 AM)philsmd Wrote: No, that's also not 100% correct.

The FAQ (https://hashcat.net/wiki/doku.php?id=fre..._questions) already says that "The only parameters allowed when restoring a session are --restore and --session (optional)"

so the command should be just:
Code:
hashcat64 --restore --session save


Attached Files
.zip   mio.zip (Size: 341 bytes / Downloads: 0)
Reply
#10
the full command is:
Code:
hashcat64 --restore --session save
Reply