Am I waisting my time?
#1
Script Kitty, trying to learn linux & hashcat.

I have a radeon 6950 HD with a FX AMD 8core processor.

Tried to get both to work together in Windows 7 & K a l i Linux

No success.

Windows 7 - will work for 1 min @ 50000 H/s then it crashes the whole computer. It does say OpenCL self test failed.
I ran the instructions found here
This did not help, I'm not sure if "AMD Radeon Software Crimson Edition" (15.12 or later)" really supports this card.

K a l i - it completely ignores my gpu. I think the problem is ROCm not supporting my card?

I have checked the websites about driver support for this card and it's iffy, or non existent.
But that 1 min @ 50K H/S had me going to try other possibilities. Regular speeds on cpu only is 5K H/S.

I really appreciate any insight/advise you may have to offer.
Reply
#2
first, forget about The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali), try to use ubuntu for hashcat.
second, what command have u used ?
third, try to use latest amd driver with older hashcat version perhaps that would work.
Reply
#3
Your card is ancient. Get a new one.
Reply
#4
@Kiara, I was working on your recommendations when I noticed that the AMD drivers say:

Distributions supported:
Ubuntu 12.04.4 LTS, 14.04.2

I wonder if they will work with 17.10 or should i just get the 14.04.2?
Currently when I run with proprietary distro drivers the GPU is not recognized.

@Undeath - I agree it's old but it plays all the games I have thrown at it, I'm kinda broke and the wifiy will kill me if I spend money on a GPU. Can you recommended any cheap options that will help me crack WPA2 in a timely fashion? (maybe I can ask for a Christmas gift?)

Update:
So I gave it a try in Ubuntu 17.10 Installed the AMD drivers with the instructions found here.

Code:
root@a-desktop:/home/a/AMD Drivers# sudo dpkg -l fglrx fglrx-core fglrx-amdcccle fglrx-dev
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name           Version      Architecture Description
+++-==============-============-============-=================================
iU  fglrx          2:15.201-0ub amd64        Video driver for the AMD graphics
iU  fglrx-amdcccle 2:15.201-0ub amd64        Catalyst Control Center for the A
iU  fglrx-core     2:15.201-0ub amd64        Minimal video driver for the AMD
iU  fglrx-dev      2:15.201-0ub amd64        Video driver for the AMD graphics

However when I run config I get:

Code:
root@a-desktop:/home/a/AMD Drivers# amdconfig --adapter=all --initial -f
No protocol specified
Unable to open /etc/ati/control, please reinstall the driver.
amdconfig: No supported adapters detected



Not sure if I have it installed properly - but the gpu is still not detected with -d 2
Should I be getting "RadeonOpenCompute (ROCm)" Software Platform (1.6.180 or later)?

I did run a few test programs from AMD and it showed no errors and played the gears "clip".
Reply
#5
(12-15-2017, 07:55 PM)undeath Wrote: Your card is ancient. Get a new one.

dude seriously, get a better attitude.

as someone who's been browsing, looking for info, the amount of piss-poor attitude towards people doing hashcat on the cheap (like myself, fulltime uni student) on this forum is disheartening. Pathetic posts like yours are a mar on the forum... sharpen up and stop being an up-yourself piss-ant.
Reply
#6
(12-16-2017, 09:33 AM)ae00711 Wrote: dude seriously, get a better attitude.

It's not an attitude thing. The card is ancient and the drivers don't support a version of OpenCL needed by hashcat. Nothing wrong with cheap cards, but old cards simply won't work. You just get tired explaining that multiple times a week when then forum is already flooded with that information…
Reply
#7
@ Undeath

Thanks for elaborating, the only reason I am trying to make the card work is because it did work in windows before crashing, however you are right, It looks like OpenCl does not like the card.

All I need is a gpu? I don't see any info on support for FX processors (however it does run on cpu).
Reply