Error while running hashcat: llvm_codegen: Assertion error == 0 failed...
Hi all, 

I'm having the following error when trying to use hashcat (up-to-date from apt-get repos). Here with --stdout flag in combination with a mask modifier.
# hashcat -m 0 -a 3 -1 'hasct' --stdout ?1?1?1 
hashcat: common.c:108: llvm_codegen: Assertion `error == 0' failed.

I'm using the following OS (I know it doesn't handle OpenCL well but it worked up until now so hopefully my problem can be solved ^^)
# uname -a
Linux redonion 4.0.0-kali1-amd64 #1 SMP Debian 4.0.4-1+kali2 (2015-06-03) x86_64 GNU/Linux

It seems I get the same problem when trying to actually crack some hashes (with or without the -r flag):

hashcat -a 0 -m 300 hashes-hc /usr/share/wordlists/rockyou.txt -r ./resources/tools/password_cracking/Hob0Rules/hob064.rule --force                                                                     
hashcat (pull/1273/head) starting...

OpenCL Platform #1: The pocl project
* Device #1: pthread-Intel(R) Core(TM) i5-3210M CPU @ 2.50GHz, 2967/2967 MB allocatable, 2MCU

Hashes: 2 digests; 2 unique digests, 1 unique salts
Bitmaps: 16 bits, 65536 entries, 0x0000ffff mask, 262144 bytes, 5/13 rotates
Rules: 64

Applicable optimizers:
* Zero-Byte
* Precompute-Init
* Precompute-Merkle-Demgard
* Early-Skip
* Not-Salted
* Not-Iterated
* Single-Salt

Watchdog: Hardware monitoring interface not found on your system.
Watchdog: Temperature abort trigger disabled.
Watchdog: Temperature retain trigger disabled.

* Device #1: build_opts '-I /usr/share/hashcat/OpenCL -D VENDOR_ID=64 -D CUDA_ARCH=0 -D VECT_SIZE=4 -D DEVICE_TYPE=2 -D DGST_R0=3 -D DGST_R1=4 -D DGST_R2=2 -D DGST_R3=1 -D DGST_ELEM=5 -D KERN_TYPE=300 -D _unroll -cl-std=CL1.2'
hashcat: common.c:108: llvm_codegen: Assertion `error == 0' failed.

Anyone has any idea what is going on and how to solve it ?
Probably just (yet another) The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) issue. Can you try on a different OS?
Several google results regarding the error llvm_codegen: Assertion 'error == 0' failed indicate that installing 'clang' resolved this.

Quote:sudo apt-get install clang-3.8
Installing clang did not fix the issue.
Thanks for the suggestion though!

I don't have hashcat installed on any other OS so I'll revert snapshots for now since the apt-get upgrade somehow broke the install. Previous version I had works fine.

In the meantime, if anyone else has suggestions let me know.