hash-encoding exception
#1
So I've tried quite hard different things, found out lots I was messing up and every step has gotten me closer to figuring this out. I have a salted md5 hash string looks like 12345678123456781234567812345678:123
(32 characters in first string, 3 salt)

First I realized I encoded txt files incorrectly as ANSI instead of Unicode, as I had googled and saw someone else have similar issue, however now I am trying and instead of a line-exception error I am getting this error 

Hashfile 'hash.txt' on line 1 ( ■8): Hash-encoding exception
No hashes loaded.

now if I put the txt files as UTF-8 encoding (because it was difficult for me to find google or forum result dealing with unicode/utf-8 encoding on txt file, so trial and error) it lists the whole hash correctly with strange chars at the start:

Hashfile 'hash.txt' on line 1 (12345678123456781234567812345678:123): Hash-encoding exception
No hashes loaded.

Perhaps I have not found the correct hash type I'm using, I assume it's the mode then that's the problem then?

-m 10 -a 3 -o [output] [input] [wordlist]

can anyone point me in the right direction of what I should be looking for? Also should my txt files be utf-8 or  unicode? And what kind of hash is that example string I gave above?

EDIT: So I double checked the string examples on the wiki, I realized I didnt scroll far enough downt o notice that this hash type looks like vbulletin, which would make sense. I am now using -m 2611, and receiving the same error, no difference.
#2
Hash files are almost always ASCII. Even if the salt contains non-ASCII, your hashes file should not need to be anything but ASCII (because the salts would be hex, and the --hex-salt parameter would be used, and the hash file itself would still be ASCII).

The '' looks like unnecessary header. Your hash.txt should simply be:

Code:
12345678123456781234567812345678:123

Example:

Code:
$ echo -n 'password123' | md5sum
482c811da5d5b4bc6d497ffa98491e38  -

$ cat test.hash
482c811da5d5b4bc6d497ffa98491e38:123

$ echo "password" | hashcat --quiet -m 10 -a 0 -o test.out test.hash
$

$ cat test.out
482c811da5d5b4bc6d497ffa98491e38:123:password

(Note that --quiet is optional, and there to make my demonstration output simpler. And I use -a 3 for simplicity also, your attack will vary)
#3
Thanks! I should have checked before if it was only the mode in the first place or not, either way because of what you said it works now, I just need to make a bigger word list.