Device#2 skipped and Temp-Abort /retain-temp
Hello everybody,

First of all, a huge praise has to be made to hashcat's developers and to the entire community. The tool is just unique, so extensive, i love it.
Unfortunately, I have not used hashcat for too long. At the moment I'm learning hashacat and I'm getting to know all the functions.

Now to my actual problem:
As you can see in picture that 2 devices are detected, but only device # 1 is used. How can I solve the problem that both devices are used to crack the hashes?
I run hashcat on windows 10

My second problem is that I would like to let Hashcat run for a longer period of time, several days, possibly weeks at a time, without interruption.
The CPU temperatures are very high once hashcat is started.
For this reason, I would very much like to activate the watchdog functions. but --temp-abort = 100 commands do not work, or just ignored.
In addition, I would like to activate the function "retain-temperature", but unfortunately I do not know how.

Many thanks for any attempt to help me with my problem.

Attached Files
.jpg   hashcat.jpg (Size: 180.46 KB / Downloads: 7)
.jpg   Core-temp.JPG (Size: 29.4 KB / Downloads: 5)
Short update:

Problem one is solved, how you can see in the picture... 
Hardware. Mon # 3 is also on.
So I assume that in hardware. Mon. # 3 now the command "--gpu-temp-abort = 100" works.
But why is hardware. Mon # 1 not enabled and how can I fix this?

Thank you again for every effort to help me

Attached Files
.jpg   solved1.jpg (Size: 98.86 KB / Downloads: 9)
device #1 is your onboard gpu, device #2 your cpu. I guess the onboard gpu simply doesn't have a dedicated temp sensor.
Thank you undeath.

I have two more question. after these i will be quiet for a while Smile

after hashcat run 56 minutes, it was aborted due to high GPU temperatures.
Is it possible to install a command to set up a checkpoint as soon as the temperatures are too high?
so you do not always have to start over.

 Does the command "--gpu-temp-retain = 80" still exist in the current version?

"nvmlDeviceGetFanSpeed(): Not Supported"   it has to do with the ventilation system ??

Any idea how i can solve that problem too ?
gpu-temp-retain was removed quite a while ago. You can always check --help if you want to know what options are available.

You can restore hashcat sessions using the --restore option. See

If you're cracking on a laptop, that's not recommended and may cause permanent damage to your device. Those things are not built for running on full load all the time.
Thank you for your words.

because the laptop is relatively new, I also wanted to use the --gpu-temp-retain =. ...
then I have to start slowly and wait until a normal pc comes here Smile