"Cannot find an OpenCL ICD loader library." error
I'm having similar issues as this user here: https://hashcat.net/forum/thread-5938.html

When I run

./hashcat64.bin --benchmark

using a freshly downloaded copy of the hashcat binaries from this site, I get this error:

Cannot find an OpenCL ICD loader library.

You are probably missing the native OpenCL runtime or driver for your platform.

* AMD GPUs on Linux require this runtime and/or driver:

  "RadeonOpenCompute (ROCm)" Software Platform (1.6.180 or later)

* Intel CPUs require this runtime and/or driver:

  "OpenCL Runtime for Intel Core and Intel Xeon Processors" (16.1.1 or later)

* Intel GPUs on Linux require this runtime and/or driver:

  "OpenCL 2.0 GPU Driver Package for Linux" (2.0 or later)

* NVIDIA GPUs require this runtime and/or driver:

  "NVIDIA Driver" (367.x or later)

I am running ubuntu 18.04 on a machine with:
  • Linux kernel: 4.15.0-43-generic
  • CPU: Intel i7 6700K
  • GPU: Nvidia GTX 1070

As the user(s) in the thread had done, running "find / libOpenCL.so" results in:

find: ‘libOpenCL.so’: No such file or directory

The Nvidia driver version and the OpenCL's version appear to match, 390.116. 
$ cat /proc/driver/nvidia/version

NVRM version: NVIDIA UNIX x86_64 Kernel Module  390.116  Sun Jan 27 10:21:36 EST 2019

GCC version:  gcc version 7.3.0 (Ubuntu 7.3.0-16ubuntu3)

$ sudo find / -iname '*OpenCL.so*'

find: ‘/run/user/1000/gvfs’: Permission denied





I have tried to follow the instructions in https://hashcat.net/faq/wrongdriver, including the repeated purgings and reinstallation and I am still getting this error.  How should I fix this?

Also apologies for the excessive spacing. I cannot seem to stop the forum software from adding them.
You need to install an icd loader. On ubuntu you need to install ocl-icd-libopencl1 (and possibly nvidia-opencl-icd-340)