Issue Cracking Simple Password
Good evening. Iv been trying to crack my own wpa2 wifi password that I have set to password123. 

I have created a simple wordlist just containing the one word and It finds it. However when I run it against a larger word list again with the word correctly in the file it fails to find it.

This is happening with AirCrack as well. Does anyone know what I could be doing wrong.

Im running on the Mac using:

hashcrack -m 2500 (name of file) (name of word list)

Thanks for any help its getting annoying now.

Quick edit. Iv tried the hashcat test file and it does the same. Also tried adding two words to the wordlist the correct one and a bogus one and it only returns the top one in the list.

Tried installing and running through home-brew and also directly compiling. Same on The-Distribution-Which-Does-Not-Handle-OpenCL-Well (Kali) it just will not find the correct password if there is more than on word in the list. What could be causing it to do it on multiple installations. Im also using the test file from hashcat to no avail.